Bug 194575 - Inputting " " caused the IDE to hang for 10s
Inputting " " caused the IDE to hang for 10s
Status: RESOLVED DUPLICATE of bug 194559
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-21 10:56 UTC by AlexMiller
Modified: 2011-01-28 09:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (5.23 KB, application/nps)
2011-01-21 10:56 UTC, AlexMiller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AlexMiller 2011-01-21 10:56:53 UTC
This bug was originally marked as duplicate of bug 181584, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201012150001)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.1-b03-307, Java(TM) SE Runtime Environment, 1.6.0_22-b04-307-10M3261
OS: Mac OS X

User Comments:
AlexMiller: While editing a PHP and HTML file, I entered " " at the end of this line:
<img src="/assets/common/icons/blue-document-import.png" class="icon" border="0" />&nbsp;Import:&nbsp;

I was replacing a single space character with &nbsp;. The first instance on that line worked fine, but after typing "&" on the second instance, the IDE became unresponsive for 10 seconds.

The only thing I can some up with is that the IDE hung trying to figure out what options to display in the autocomplete tooltip.

Original Summary:
LowPerformance took 10684 ms.



Maximum slowness yet reported was 10684 ms, average is 10684
Comment 1 AlexMiller 2011-01-21 10:56:57 UTC
Created attachment 105236 [details]
nps snapshot
Comment 2 Dusan Balek 2011-01-28 09:35:33 UTC

*** This bug has been marked as a duplicate of bug 194559 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo