Bug 194559 - LowPerformance took 3142 ms.
LowPerformance took 3142 ms.
Status: RESOLVED INCOMPLETE
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.0
All All
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 194575 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-21 06:09 UTC by stjohnjohnson
Modified: 2011-02-02 17:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (5.21 KB, application/nps)
2011-01-21 06:09 UTC, stjohnjohnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stjohnjohnson 2011-01-21 06:09:08 UTC
This bug was originally marked as duplicate of bug 181584, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.1-b03-307, Java(TM) SE Runtime Environment, 1.6.0_22-b04-307-10M3261
OS: Mac OS X

User Comments:
stjohnjohnson: Typing & in an alt tag in HTML 5



Maximum slowness yet reported was 3142 ms, average is 3142
Comment 1 stjohnjohnson 2011-01-21 06:09:13 UTC
Created attachment 105226 [details]
nps snapshot
Comment 2 Dusan Balek 2011-01-28 08:55:06 UTC
Seems like a JDK problem - 16 calls to java.awt.FontMetrics.getStringBounds(...) took 2988 ms (as can be seen from the attached NPS snapshot). That's strange. Are you experiencing similar problems often while invoking code completion?
Comment 3 Dusan Balek 2011-01-28 09:05:20 UTC
OOPS - incorrectly marked as FIXED.
Comment 4 Dusan Balek 2011-01-28 09:35:33 UTC
*** Bug 194575 has been marked as a duplicate of this bug. ***
Comment 5 stjohnjohnson 2011-02-02 17:38:13 UTC
It's happened a few other times, but nothing I could directly figure out.  Usually only during HTML completion


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo