Bug 194478 - "Connection refused" during starting mysql server from IDE.
"Connection refused" during starting mysql server from IDE.
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: MySQL
7.0
PC Windows 7
: P3 (vote)
: 7.1
Assigned To: Jiri Rechtacek
issues@db
:
: 194479 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 15:27 UTC by Tomas Danek
Modified: 2012-09-15 07:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2011-01-19 15:27:48 UTC
Product Version: NetBeans IDE Dev (Build 201101170000)
Java: 1.6.0_22; Java HotSpot(TM) 64-Bit Server VM 17.1-b03-307
System: Mac OS X version 10.6.6 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/dev
--------------
using MAMP as Mysql server

- server is correctly autodetected in IDE, even commands for starting and stopping
- filled in also password for root user, checked to remember password 
- when invoking Start command from server popup, server properties dialog appears with "Connection refused" message. Server is started, but from IDE it looks like it is not - i.e. start action is enabled, stop action is disabled.
Comment 1 Tomas Danek 2011-01-19 15:40:16 UTC
*** Bug 194479 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Rechtacek 2011-10-26 14:09:42 UTC
Reopen if it's still a valid problem. Thanks
Comment 3 muthuananth 2012-09-15 00:35:34 UTC
I am trying to connect MySQL5.1 in Netbeans7.0.1 RC1 build in Windows 7.

But there connection refused error has been occured.

In Services --> Database --> RegisterMySQLServer i have given this details.

Basic Prop

HostName : localhost port : 3306 uname : root pwd : root

admin prop

Path/url admin tool : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysql.exe

arg : <-- i have kept blank-->

Path to start cmd : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld.exe

arg : <-- i have kept blank-->

path to stop cmd : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqladmin.exe

arg : -u root -proot stop

But connection refused error is coming. I checked jar file placed in correct place. And using mysql-connector-java-5.1.13-bin.jar.

Anybody knows solution, kindly help me

M.Muthu Ananth Haiahtum Software muthu.ananth@gmail.com
Comment 4 Jiri Rechtacek 2012-09-15 07:09:52 UTC
(In reply to comment #3)
> I am trying to connect MySQL5.1 in Netbeans7.0.1 RC1 build in Windows 7.
Why did you choose such relic? Install latest NetBeans IDE instead - http://netbeans.org/downloads/

> But there connection refused error has been occured.
> 
> In Services --> Database --> RegisterMySQLServer i have given this details.
> 
> Basic Prop
> 
> HostName : localhost port : 3306 uname : root pwd : root
> 
> admin prop
> 
> Path/url admin tool : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysql.exe
> 
> arg : <-- i have kept blank-->
> 
> Path to start cmd : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld.exe
> 
> arg : <-- i have kept blank-->
> 
> path to stop cmd : C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqladmin.exe
> 
> arg : -u root -proot stop
> 
> But connection refused error is coming. I checked jar file placed in correct
> place. And using mysql-connector-java-5.1.13-bin.jar.
> 
> Anybody knows solution, kindly help me

Try the latest version of IDE - if it doesn't work still, file please new issue instead of reopening old aged issue. Thanks
> 
> M.Muthu Ananth Haiahtum Software muthu.ananth@gmail.com


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo