Bug 194273 - Exceptions on start debugging (WindowsXP/MinGW/msys)
Exceptions on start debugging (WindowsXP/MinGW/msys)
Status: RESOLVED DUPLICATE of bug 193740
Product: cnd
Classification: Unclassified
Component: Debugger
7.0
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Egor Ushakov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-12 15:52 UTC by soldatov
Modified: 2011-01-13 07:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-01-12 15:52:42 UTC
All GDB automatic tests fails on start debugging (WindowsXP/MinGW/msys)

SEVERE [org.openide.util.Exceptions]
java.io.IOException: CreateProcess error=2, ?? ??????? ????? ????????? ????
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(Unknown Source)
	at java.lang.ProcessImpl.start(Unknown Source)
Caused: java.io.IOException: Cannot run program "mkfifo.exe": CreateProcess error=2, ?? ??????? ????? ????????? ????
	at java.lang.ProcessBuilder.start(Unknown Source)
[catch] at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$LocalIOProxy.createNewFifo(IOProxy.java:254)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$LocalIOProxy.<init>(IOProxy.java:228)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy.create(IOProxy.java:81)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.OutputPack.<init>(OutputPack.java:59)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOPack.create(IOPack.java:139)
	at org.netbeans.modules.cnd.debugger.gdb2.Gdb$Factory.start(Gdb.java:289)
	at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.start2(GdbDebuggerImpl.java:406)
	at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.start(GdbDebuggerImpl.java:384)
	at org.netbeans.modules.cnd.debugger.gdb2.actions.GdbStartActionProvider.doAction(GdbStartActionProvider.java:180)
	at org.netbeans.modules.cnd.debugger.gdb2.actions.GdbStartActionProvider.postAction(GdbStartActionProvider.java:130)
	at org.netbeans.api.debugger.ActionsManager.postAction(ActionsManager.java:240)
	at org.netbeans.api.debugger.DebuggerManager.startDebugging(DebuggerManager.java:395)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.debugNoAsk(DebuggerManager.java:1018)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.startDebugger(DebuggerManager.java:989)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.debug(DebuggerManager.java:1217)
	at org.netbeans.modules.cnd.debugger.common2.DbgActionHandler$2.run(DbgActionHandler.java:127)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at org.netbeans.jemmy.QueueTool$JemmyQueue.dispatchEvent(QueueTool.java:610)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
SEVERE [org.openide.util.Exceptions]
java.io.IOException: CreateProcess error=2, ?? ??????? ????? ????????? ????
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(Unknown Source)
	at java.lang.ProcessImpl.start(Unknown Source)
Caused: java.io.IOException: Cannot run program "mkfifo.exe": CreateProcess error=2, ?? ??????? ????? ????????? ????
	at java.lang.ProcessBuilder.start(Unknown Source)
[catch] at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$LocalIOProxy.createNewFifo(IOProxy.java:254)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$LocalIOProxy.<init>(IOProxy.java:230)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy.create(IOProxy.java:81)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.OutputPack.<init>(OutputPack.java:59)
	at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOPack.create(IOPack.java:139)
	at org.netbeans.modules.cnd.debugger.gdb2.Gdb$Factory.start(Gdb.java:289)
	at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.start2(GdbDebuggerImpl.java:406)
	at org.netbeans.modules.cnd.debugger.gdb2.GdbDebuggerImpl.start(GdbDebuggerImpl.java:384)
	at org.netbeans.modules.cnd.debugger.gdb2.actions.GdbStartActionProvider.doAction(GdbStartActionProvider.java:180)
	at org.netbeans.modules.cnd.debugger.gdb2.actions.GdbStartActionProvider.postAction(GdbStartActionProvider.java:130)
	at org.netbeans.api.debugger.ActionsManager.postAction(ActionsManager.java:240)
	at org.netbeans.api.debugger.DebuggerManager.startDebugging(DebuggerManager.java:395)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.debugNoAsk(DebuggerManager.java:1018)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.startDebugger(DebuggerManager.java:989)
	at org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerManager.debug(DebuggerManager.java:1217)
	at org.netbeans.modules.cnd.debugger.common2.DbgActionHandler$2.run(DbgActionHandler.java:127)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at org.netbeans.jemmy.QueueTool$JemmyQueue.dispatchEvent(QueueTool.java:610)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
SEVERE [org.openide.util.Exceptions]
java.lang.NullPointerException
[catch] at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$OutputReaderThread.run(IOProxy.java:210)
Comment 1 Egor Ushakov 2011-01-13 07:31:57 UTC

*** This bug has been marked as a duplicate of bug 193740 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo