Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 194235 - scala plugin not available for install
scala plugin not available for install
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Scala
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: _ dcaoyuan
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-11 23:37 UTC by maciek252
Modified: 2011-05-19 18:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maciek252 2011-01-11 23:37:31 UTC
The Scala plugin is not listed among the plugins available for installation. This concerns the released builds of the 7.0 dev versions, but also 6.9.1. I managed to find and install it for one of the 7 betas, but not other ones.
Comment 1 Jesse Glick 2011-01-12 16:46:07 UTC
Can be built from sources. I was forced to remove it from dev AU since <scalac> was frequently breaking on the CI server; even when run locally it can take a couple of minutes to compile ~40 files, and takes a lot of memory. Probably should be moved out of contrib to a standalone project on java.net and built using a dedicated Hudson job.
Comment 2 tpistols 2011-02-02 03:00:34 UTC
When trying to build this from source using HG checked out source, I'm getting 

build-init:
Loading module list from C:\Users\scampbell\Documents\NetBeansProjects\nbsrc\mai
n\nbbuild\nbproject\private\scan-cache-full.ser
[parseprojectxml] The module org.jdesktop.layout has been deprecated

BUILD FAILED
C:\Users\scampbell\Documents\NetBeansProjects\nbsrc\main\contrib\scala.kit\build
.xml:89: The following error occurred while executing this line:
C:\Users\scampbell\Documents\NetBeansProjects\nbsrc\main\nbbuild\templates\proje
ctized.xml:100: Cannot compile against a module: C:\Users\scampbell\Documents\Ne
tBeansProjects\nbsrc\main\nbbuild\netbeans\ide\modules\org-netbeans-libs-lucene.
jar because of dependency: org.netbeans.libs.lucene/1 > 2.13
Comment 3 Jesse Glick 2011-02-02 14:13:08 UTC
Yes, the Lucene library was updated and the Scala editor would need a dependency on the new version (plus possibly compatibility fixes, though unlikely).
Comment 4 jcampbell 2011-02-17 04:15:31 UTC
I changed the "Major Release Version" and "Specific Version" version info for the Library "Lucene Integration" on the "Scala Editor" and "Scala Refactoring" projects and I was able to compile/install and use the Scala Plugin just fine on the NetBeans 7.0 Dev 201102160501.


Here is the Diffs:

diff --git a/scala.refactoring/nbproject/project.xml b/scala.refactoring/nbproject/project.xml
--- a/scala.refactoring/nbproject/project.xml
+++ b/scala.refactoring/nbproject/project.xml
@@ -36,17 +36,15 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <release-version>1</release-version>
-                        <specification-version>2.13</specification-version>
+                        <release-version>3</release-version>
+                        <specification-version>3.0</specification-version>
                     </run-dependency>
                 </dependency>

AND


diff --git a/scala.editor/nbproject/project.xml b/scala.editor/nbproject/project.xml
--- a/scala.editor/nbproject/project.xml
+++ b/scala.editor/nbproject/project.xml
@@ -39,17 +39,15 @@
                     <build-prerequisite/>
                     <compile-dependency/>
                     <run-dependency>
-                        <release-version>1</release-version>
-                        <specification-version>2.13</specification-version>
+                        <release-version>3</release-version>
+                        <specification-version>3.0</specification-version>
                     </run-dependency>
                 </dependency>
Comment 5 jcampbell 2011-02-24 22:41:46 UTC
Any progress of getting this back in as an available plugin NetBeans 7.0?

It would be UNFORTUNATE to not have this as a part of the NetBeans 7.0 release!  (it is a plugin that works great and the only means of supporting Scala in NetBeans)
Comment 6 Jesse Glick 2011-03-23 15:03:42 UTC
If Caoyuan Deng - or someone else - is willing to maintain the code somehow, I could try to push it into its own repository somewhere and set up a CI job for it. This would at least produce an update site URL that users could add to NB manually; could also be published on Plugin Portal if desired.

BTW http://groups.google.com/group/scala-netbeans/browse_thread/thread/efd4d07a19e53da4 is unanswered. Also https://sourceforge.net/tracker/index.php?func=detail&aid=3157653&group_id=192439&atid=941398 is unanswered. https://sourceforge.net/projects/erlybird/ looks abandoned and http://wiki.netbeans.org/Scala69 says nothing about 7.0.
Comment 7 artisan 2011-04-15 19:14:53 UTC
No news yet ?
Comment 8 tpistols 2011-05-19 18:19:25 UTC
Just like to add my voice requesting an updated build for 7.x
We're close to GA for our first major product featuring a scala-based server on the backend.  I love using NB + Scala, and it sure would help in promoting both within our company.
Comment 9 _ dcaoyuan 2011-05-19 18:26:51 UTC
For NetBeans 7.0 + Scala 2.8.x, please get it from:
http://plugins.netbeans.org/plugin/36598/?show=true

To follow the latest progress, here it is:
http://java.net/projects/nbscala
Or,
https://github.com/dcaoyuan/nbscala


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo