Bug 194038 - JBoss AOP Exception when deploying WAR file for JBoss 5.x AS
JBoss AOP Exception when deploying WAR file for JBoss 5.x AS
Status: RESOLVED INCOMPLETE
Product: serverplugins
Classification: Unclassified
Component: JBoss
7.0
PC Mac OS X
: P3 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 08:58 UTC by toni_braecksten
Modified: 2011-01-13 08:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Maven war project failing to auto deploy on JBoss AS 5.x (14.41 KB, application/zip)
2011-01-13 08:08 UTC, toni_braecksten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description toni_braecksten 2011-01-05 08:58:16 UTC
Referring to the issue http://netbeans.org/bugzilla/show_bug.cgi?id=177230 I 'd like to point out to an AOP exception logged in the IDE log when a WAR file is deployed to JBoss 5.x AS via NetBeans "DeployOnSave" function. I am not sure, if this exception is the reason for the failed "DeployOnSave" update when changing any JSP or Java file. If this is the case, please try to fix it. Below you can find the stacktrace of the IDE log.

Best regards
tb


INFO [org.netbeans.modules.j2ee.jboss4.JBDeployer]
java.lang.NoSuchMethodException: AOPProxy$2.load()
        at java.lang.Class.getDeclaredMethod(Class.java:1937)
        at
org.netbeans.modules.j2ee.jboss4.JBoss5ProfileServiceProxy.isReady(JBoss5ProfileServiceProxy.java:104)
[catch] at
org.netbeans.modules.j2ee.jboss4.JBDeployer.isApplicationReady(JBDeployer.java:330)
        at
org.netbeans.modules.j2ee.jboss4.JBDeployer.waitForUrlReady(JBDeployer.java:283)
        at org.netbeans.modules.j2ee.jboss4.JBDeployer.run(JBDeployer.java:243)
        at
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
WARNING [org.openide.filesystems.Ordering]: Not all children in
Loaders/text/x-ant+xml/Factories/ marked with the position attribute
: [org-apache-tools-ant-module-loader-AntProjectDataLoader.instance], but some
are: [org.apache.tools.ant.module.resources.xml-ergonomics.instance]
WARNING [org.openide.awt.HtmlRenderer]: Malformed or unsupported HTML
WARNING [org.openide.awt.HtmlRenderer]:  
<html><html><font&nbsp;color="#808080">&lt;Enter&nbsp;new&nbsp;watch&gt;</font></html></html>
WARNING [org.openide.awt.HtmlRenderer]:         ^
WARNING [org.openide.awt.HtmlRenderer]:  Full HTML
string:<html><html><font&nbsp;color="#808080">&lt;Enter&nbsp;new&nbsp;watch&gt;</font></html></html>
WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base
passed when looking up docs/jstl11-doc.zip at
org.netbeans.modules.web.core.syntax.JspSyntaxSupport.initHelp(JspSyntaxSupport.java:779)
WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base
passed when looking up docs/jsf12-tlddoc.zip at
org.netbeans.modules.web.core.syntax.JspSyntaxSupport.initHelp(JspSyntaxSupport.java:808)
WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base
passed when looking up docs/struts-tags.zip at
org.netbeans.modules.web.core.syntax.JspSyntaxSupport.initHelp(JspSyntaxSupport.java:821)
WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base
passed when looking up docs/syntaxref20.zip at
org.netbeans.modules.web.core.syntax.JspSyntaxSupport.initCompletionData(JspSyntaxSupport.java:918)
Comment 1 toni_braecksten 2011-01-05 11:47:06 UTC
Changed component to  JBoss
Comment 2 Petr Hejl 2011-01-12 11:07:49 UTC
Deploy on Save has never been supported on JBoss. The exception is just info. If it does not cause other problems it is ok.

Would be interesting to know the exact version and configuration of server/domain possibly with sample to app to reproduce.
Comment 3 toni_braecksten 2011-01-13 08:05:02 UTC
Thanks for feedback.
Since I am a Netbeans newbie - but enthusiastic one - I wasn't aware that there is no DeployOnSave support for JBoss AS. The problem is quite easy to reproduce because the automatic update of the JBoss deployment fails overtime - that was my experience. I assume the main problem is that the war/ear artifact is not deployed as an exploded file by the Netbeans IDE. If the Netbeans Maven plugin would deploy the file in exploded mode - e.g. like the maven-cargo-plugin - then the DeployOnSave function might work.
Nevertheless I will attach a sample project. For my tests I use the JBoss AS version 5.0.0 
with default server configuration.
Comment 4 toni_braecksten 2011-01-13 08:08:23 UTC
Created attachment 104947 [details]
Maven war project failing to auto deploy on JBoss AS 5.x

Maven war project that cannot be automatically deployed on save for JBoss AS 5.x


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo