Bug 193740 - NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$OutputReaderThread.run
NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.io...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
7.0
PC Windows 7
: P2 (vote)
: 7.0
Assigned To: Egor Ushakov
issues@cnd
EXCEPTIONS_REPORT
: REGRESSION
: 194273 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-22 15:23 UTC by Alexander Pepin
Modified: 2011-02-11 21:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (140 bytes, text/plain)
2010-12-22 15:23 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2010-12-22 15:23:21 UTC
Build: NetBeans IDE Dev (Build 201012220001)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.0-b17, Java(TM) SE Runtime Environment, 1.6.0_21-b07
OS: Windows 7

User Comments:
apepin: Steps to reproduce:
- create Welcome sample
- set Standard Output as a console type
- do Step into

GUEST: Debug Main Project




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.debugger.common2.debugger.io.IOProxy$OutputReaderThread.run(IOProxy.java:210)
Comment 1 Alexander Pepin 2010-12-22 15:23:25 UTC
Created attachment 104400 [details]
stacktrace
Comment 2 Alexander Pepin 2010-12-22 15:41:50 UTC
This happens on any Windows system with both MSYS and cygwin.
Comment 3 Egor Ushakov 2010-12-22 20:34:38 UTC
standard output console type never worked on windows, see bug 148204, I will re-disable it in new infrastructure
Comment 4 Egor Ushakov 2010-12-22 21:33:43 UTC
not a regression
Comment 5 Egor Ushakov 2010-12-22 21:36:33 UTC
The problem here is that with msys on windows "internal terminal" is also not available (see bug 193241), so only external terminal really works for debugging.
But how to indicate that in GUI?
Comment 6 Alexander Pepin 2010-12-29 13:50:33 UTC
IT IS A REGRESSION! Previously a user can not only enter anything into Output window while debugging. Now it's impossible to debug any application using Standard Output.
Comment 7 Alexander Pepin 2010-12-29 13:54:20 UTC
Sorry for mistake "Previously a user could not..."
Comment 8 Egor Ushakov 2011-01-13 07:31:57 UTC
*** Bug 194273 has been marked as a duplicate of this bug. ***
Comment 9 Egor Ushakov 2011-01-13 16:14:01 UTC
fixed in:
http://hg.netbeans.org/cnd-main/rev/0f2d8a39fa53
now on Windows Standard Output is switched to External Terminal and warning is shown to the user.
Comment 10 Quality Engineering 2011-01-14 06:08:17 UTC
Integrated into 'main-golden', will be available in build *201101140000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0f2d8a39fa53
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #193740 (NPE in IOProxy$OutputReaderThread) - disabled standard output on windows (swithing to external terminal)
Comment 11 AlyonaStashkova 2011-02-11 21:46:28 UTC
Added to the Known Issues: C/C++ section of the NetBeans IDE 7.0 Beta 2 Release Notes as follows:

Issue #193740: On Windows platform, the "Use external terminal" warning displays when the Standard Output console is used for debugging.

    Description: The Standard Output console type is not used for debugging on Windows platform.

    Workaround: Use the Internal Terminal in the CYGWIN environment and the External Terminal in the MSYS environment instead.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo