Bug 193709 - Netbeans 6.9.1 dead locked (deadlocked/dead-locked) when selecting component in GUI builder
Netbeans 6.9.1 dead locked (deadlocked/dead-locked) when selecting component ...
Status: RESOLVED DUPLICATE of bug 190774
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-21 21:54 UTC by haihovu
Modified: 2011-02-03 18:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace of Netbeans capturing the deadlock (24.82 KB, application/octet-stream)
2010-12-21 21:54 UTC, haihovu
Details
FTD showing the deadlock after opening a form in 7.0beta (15.61 KB, text/plain)
2011-01-24 08:51 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haihovu 2010-12-21 21:54:35 UTC
Created attachment 104370 [details]
Stack trace of Netbeans capturing the deadlock

Background:
Platform: CentOS 5.5 with latest patches as of time of writing, running inside VMware ESXi 4.1
JDK: Sun 1.6.0_23 (latest as of time of writing)
Netbeans: 6.9.1 with latest patches (201011082200)

Encountered 2 deadlocks (between "Property Sheet" and "AWT-EventQueue-1") while using the GUI editor, both times appeared to be triggered by the selection of a dialog component. These problems were encountered soon after the application of the latest Netbeans patches, and weren't seen previously.

Stack trace: see attachment
Comment 1 Vitezslav Stejskal 2011-01-24 08:50:22 UTC
The same happened to me in 7.0beta when opening a form, attaching threaddump...
Comment 2 Vitezslav Stejskal 2011-01-24 08:51:40 UTC
Created attachment 105292 [details]
FTD showing the deadlock after opening a form in 7.0beta
Comment 3 Tomas Pavek 2011-02-03 18:51:36 UTC
The first reported deadlock is bug 190774, already fixed.

The second report is bug 187697 appearing on JDK6 u21 and u22.

*** This bug has been marked as a duplicate of bug 190774 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo