Bug 193492 - [70cat] AssertionError: isSubtype 20
[70cat] AssertionError: isSubtype 20
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 13:28 UTC by ytn01
Modified: 2011-10-20 14:25 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.58 KB, text/plain)
2010-12-16 13:28 UTC, ytn01
Details
stacktrace (3.01 KB, text/plain)
2011-04-06 22:36 UTC, alied
Details
stacktrace (3.01 KB, text/plain)
2011-04-06 23:18 UTC, alied
Details
stacktrace (3.01 KB, text/plain)
2011-04-07 05:24 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ytn01 2010-12-16 13:28:22 UTC
This bug was originally marked as duplicate of bug 161450, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201012050001)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows 7

User Comments:
ytn01: I was writing some java code inside the source view of a JFrame GUI file.
The Exception was generated when a code was being expanded when object members were being listed.




Stacktrace: 
java.lang.AssertionError: isSubtype 20
   at com.sun.tools.javac.code.Types$5.visitType(Types.java:387)
   at com.sun.tools.javac.code.Types$5.visitType(Types.java:368)
   at com.sun.tools.javac.code.Type.accept(Type.java:96)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visit(Types.java:3516)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:364)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:340)
Comment 1 ytn01 2010-12-16 13:28:26 UTC
Created attachment 104152 [details]
stacktrace
Comment 2 alied 2011-04-06 22:36:43 UTC
Created attachment 107570 [details]
stacktrace

playing with new Action annotations:

 @ActionReference(id ="", path="Menu/Reno")
 @ActionReference(path="Toolbars/Reno")
Comment 3 alied 2011-04-06 23:18:40 UTC
Created attachment 107572 [details]
stacktrace
Comment 4 alied 2011-04-07 05:24:39 UTC
Created attachment 107578 [details]
stacktrace

Every time I add Action anotations, and I don't have the imports, I have this exception.
Comment 6 Quality Engineering 2011-10-20 14:25:36 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/7a9f5e3b0ade
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #179621, #193492, and #203871 fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo