Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 19346 - Need to uninstall module if moudle becomes corrupt
Need to uninstall module if moudle becomes corrupt
Status: CLOSED DUPLICATE of bug 20323
Product: platform
Classification: Unclassified
Component: Autoupdate
3.x
PC Windows ME/2000
: P3 with 1 vote (vote)
: 3.x
Assigned To: akemr
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-11 13:43 UTC by Jaromir Uhrik
Modified: 2003-06-30 13:49 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2002-01-11 13:43:41 UTC
This issue is transferred from bugtraq (4621993).

Customer should be able to uninstall a module if module becomes corrupt or is
affecting other functionality. In addition customer should be able to reinstall
the module in question. 
A partial solution could be to add an additional state (or flag) to a disabled
module so when user access the update center the user can then download and
install the flagged (corrupt) module.
Comment 1 akemr 2002-01-11 16:01:35 UTC
Definitely RFE.
Comment 2 akemr 2002-01-24 13:45:49 UTC
Jesse, what do you think about this suggested partial solution?
Comment 3 Jesse Glick 2002-01-24 18:45:37 UTC
The flagging thing sounds like very strange UI, I am not sure what the
purpose is. Better to just permit direct deletion.

Suggest a pure abstract class in org.netbeans.core.modules that would
delete a module though it be a scanned module. ModuleNode could look
for such a thing in lookup and make scanned module nodes deletable
using it, if present.

However that would be a hack. Prefer to wait for Looks to make it
possible to set an "AutoUpdate look" on the ModuleNode, which would
handle deletion of tracked modules, as well as the NewType for NBMs.
Comment 4 gaikokujin 2002-02-07 22:29:22 UTC
See Radiance case Case ID: 62836648  Task ID: 64641095:

"how to cleanly uninstall / rollback to the previous version, the 
SOAP TPM module"

This is particularly an issue with Tech. Preview Modules, which are 
beta overwrites of the fcs modules (ex: webservices.jar)
Comment 5 akemr 2002-02-08 10:54:03 UTC
Marking as duplicate of #20323, which is more complex.

*** This issue has been marked as a duplicate of 20323 ***
Comment 6 Jaromir Uhrik 2002-02-15 11:22:53 UTC
Verified - duplicate.
Comment 7 Quality Engineering 2003-06-30 13:49:21 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo