Bug 193456 - [70cat] AssertionError at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext
[70cat] AssertionError at org.netbeans.modules.maven.indexer.NexusRepositoryI...
Status: RESOLVED DUPLICATE of bug 195541
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P3 (vote)
: 7.0
Assigned To: Antonin Nebuzelsky
issues@projects
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks: 190182
  Show dependency treegraph
 
Reported: 2010-12-15 18:46 UTC by stopd
Modified: 2011-03-07 14:58 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.56 KB, text/plain)
2010-12-15 18:46 UTC, stopd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stopd 2010-12-15 18:46:35 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-6328-on-101215)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows 7

User Comments:
aquaglia: Opening Maven dependency details

lmorissette: occured while attempting to view dependency properties for xom

stopd: Checked out ant 1.7.1 sources from subversion and opened the project. Exception occured when I tried to open the maven dependency graph for the main project.

jsacha: ?




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext(NexusRepositoryIndexerImpl.java:263)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.access$400(NexusRepositoryIndexerImpl.java:161)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl$8.run(NexusRepositoryIndexerImpl.java:802)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl$8.run(NexusRepositoryIndexerImpl.java:800)
   at org.openide.util.Mutex.writeAccess(Mutex.java:436)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.getRecords(NexusRepositoryIndexerImpl.java:800)
Comment 1 stopd 2010-12-15 18:46:38 UTC
Created attachment 104133 [details]
stacktrace
Comment 2 Jesse Glick 2011-01-07 18:19:35 UTC
Looks like a regression caused by per-repo mutex? Not obvious how it could happen, but my guess is that getRepoMutex(String) should have been synchronized - perhaps there is a race condition whereby getRecords obtains one Mutex for a given repo, in parallel another thread calls getRepoMutex and stores its own Mutex there, and then loadIndexingContext is holding a lock on the wrong mutex.
Comment 3 Exceptions Reporter 2011-03-03 11:37:15 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=173427
Comment 4 Antonin Nebuzelsky 2011-03-07 14:58:16 UTC
Last build in the list of reports is 110214. Resolving as a dup of fixed issue 195541 which got integrated on 110218.

*** This bug has been marked as a duplicate of bug 195541 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo