Bug 193339 - NoClassDefFoundError: Could not initialize class org.openide.actions.ToolsAction
NoClassDefFoundError: Could not initialize class org.openide.actions.ToolsAction
Status: RESOLVED DUPLICATE of bug 193119
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-13 19:03 UTC by obalyuk
Modified: 2011-04-13 16:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.18 KB, text/plain)
2010-12-13 19:03 UTC, obalyuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description obalyuk 2010-12-13 19:03:37 UTC
Build: NetBeans IDE Dev (Build 201012060001)
VM: OpenJDK Client VM, 19.0-b09, OpenJDK Runtime Environment, 1.6.0_20-b20
OS: Linux

User Comments:
GUEST: compilation d'un projet

GUEST: ???? ??

obalyuk: error happens when I rightclick the project tree.

obalyuk: was expanding project tree when error occured.
Had multiple projects open (PHP Projects).




Stacktrace: 
java.lang.NoClassDefFoundError: Could not initialize class org.openide.actions.ToolsAction
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(NativeConstructorAccessorImpl.java:0)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
   at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
   at org.openide.util.SharedClassObject.createInstancePrivileged(SharedClassObject.java:658)
   at org.openide.util.SharedClassObject$SetAccessibleAction.run(SharedClassObject.java:1018)
Comment 1 obalyuk 2010-12-13 19:03:40 UTC
Created attachment 104026 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-04-13 16:23:33 UTC
Static initializer of ToolsAction is
	at org.openide.actions.ToolsAction.<clinit>(ToolsAction.java:94)
interrupted by "GUI is not responsive" exception. Jesse, what is your take?
Comment 3 Jesse Glick 2011-04-13 16:58:43 UTC
(In reply to comment #2)
> Static initializer of ToolsAction is
> interrupted by "GUI is not responsive" exception.

Not as such; rather, the EQ was blocked in ToolsAction's static initializer, and that thread was stopped in an attempt to get it restarted. (Otherwise the IDE might have just been deadlocked completely, causing data loss.) The stack trace is simply an indication of what EQ was doing - it is not a real exception being thrown. The real problem was already fixed.

BTW the stack traces from 6.7 & 6.8 are totally unrelated; third-party module problems, I think.

*** This bug has been marked as a duplicate of bug 193119 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo