Bug 193186 - [70cat] LowPerformance took 13797 ms.
[70cat] LowPerformance took 13797 ms.
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: execution
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Andrew Krasny
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 193378 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 18:02 UTC by esmithbss
Modified: 2010-12-23 07:09 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (13.97 KB, application/nps)
2010-12-09 18:02 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2010-12-09 18:02:50 UTC
Build: NetBeans IDE Dev (Build 201012090001)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows XP

User Comments:
GUEST: opening a term window

GUEST: I select NEW PROYECT, then select C project and here the problem ocurred... it was slow

GUEST: starting the terminal

esmithbss: Bringing up the Customize Toolbar dialog following a clean installation.

hantsy: when click terminal on Windows 7 32bit

GUEST: Cancelled on the first screen of new project dialog.
Menubar was unresponsive afterward for the time noted.



Maximum slowness yet reported was 54784 ms, average is 18257
Comment 1 esmithbss 2010-12-09 18:02:58 UTC
Created attachment 103896 [details]
nps snapshot
Comment 2 Vladimir Voskresensky 2010-12-15 21:54:39 UTC
let's evaluate exceptions as P2 issues
Comment 3 Maria Tishkova 2010-12-16 08:19:57 UTC
It has nothing to do with DLight.
Moved to "execution" but I am not sure if it is execution, remote or project system issue.

Andrew please take a look and evaluate if it is related to the execution, if it is not please move to remote
Comment 4 Andrew Krasny 2010-12-20 16:26:13 UTC
Confirmed.

The problem is that we start to get localhost info once any reference for local execution environment it is requested. And we do this in the same (sometimes AWT) thread. This operation is rather fast on *nixes, but may take a while on Windows, as this includes searching for cygwin/msys installed... 

Note, this occurs only once per IDE launch.

Need to be fixed...
Comment 5 Leonid Lenyashin 2010-12-20 16:28:00 UTC
Does not sound like a P2 (need to be fixed does not justify P2)
Comment 6 Andrew Krasny 2010-12-20 16:37:25 UTC
I would agree, but we have many (8) duplicates on this slowness report..
Comment 7 Quality Engineering 2010-12-21 08:09:50 UTC
Integrated into 'main-golden', will be available in build *201012210001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/38c03180ea7d
User: Andrew Krasny <akrasny@netbeans.org>
Log: lazy SelectModeDescriptorPanel initialization - [partfix] Bug #193186 - LowPerformance took 13797 ms
Comment 8 Maria Tishkova 2010-12-21 12:25:06 UTC
*** Bug 193378 has been marked as a duplicate of this bug. ***
Comment 9 Andrew Krasny 2010-12-21 13:25:24 UTC
changeset: http://hg.netbeans.org/cnd-main/rev/53f2ce1c902a
Comment 10 Andrew Krasny 2010-12-21 13:51:09 UTC
*** Bug 193378 has been marked as a duplicate of this bug. ***
Comment 11 Quality Engineering 2010-12-23 07:09:27 UTC
Integrated into 'main-golden', will be available in build *201012230001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/53f2ce1c902a
User: Andrew Krasny <akrasny@netbeans.org>
Log: Bug #193186 - LowPerformance took 13797 ms


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo