Bug 19294 - Add generic help support to property editors
Add generic help support to property editors
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Property Editors
3.x
All All
: P3 (vote)
: 3.x
Assigned To: akemr
issues@platform
: UI
: 21378 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-10 17:55 UTC by Rochelle Raccah
Modified: 2008-12-22 19:24 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rochelle Raccah 2002-01-10 17:55:43 UTC
Issue 12518 addresses the support of help for the DataObject editor, but makes a
suggestion for a more generic solution:

Optimally, I think this should be solved for all property editors by adding a
hint to the top level (like "title").  This hint could be handled as follows:
- if the helpID is supplied as a hint and there is no help registered already
for the innerPane to the DialogDescriptor constructor, use that in the
PropertyDialogManager's creation of the DialogDescriptor.
- if no helpID hint is supplied, use the old behavior (if the innerPane has one,
it will be used, otherwise there will be no help button)
- if both are supplied --> ask on nbui what the behavior should be

David has agreed that this a good enhancement, so I'm filing it separately.
Comment 1 akemr 2002-03-06 12:41:35 UTC
Implemented in trunk.

- new property ExPropertyEditor.PROPERTY_HELP_ID

You should use code like

propertyDescriptor.setValue( ExPropertyEditor.PROPERTY_HELP_ID, helpID )
in BeanInfo to attach helpID to custom editor of some property
Comment 2 Rochelle Raccah 2002-03-15 07:53:30 UTC
This probably makes my fix for issue 12518 redundant.  Has that code
been cleaned up?
Comment 3 akemr 2002-03-15 14:24:49 UTC
Yes, it could be cleaned - but you probably should at first
change your code from:

propertyDescriptor.setValue( DataObjectEditor.PROPERTY_HELPID, helpID )

to:
propertyDescriptor.setValue( ExPropertyEditor.PROPERTY_HELP_ID, helpID )
Comment 4 Rochelle Raccah 2002-03-15 15:18:24 UTC
But the value in DataObject editor is private and has the same value
as in ExPropertyEditor.  So (client) code which used to say
propertyDescriptor.setValue( "helpID", helpID )
should be changed to propertyDescriptor.setValue(
ExPropertyEditor.PROPERTY_HELP_ID, helpID ) but it will still work
meanwhile.  I only have an example of this (not in my real code)
anyway.  I think you can clean it up without breaking anything.
Comment 5 akemr 2002-03-15 15:20:33 UTC
*** Issue 21378 has been marked as a duplicate of this issue. ***
Comment 6 akemr 2002-03-15 15:21:37 UTC
*** Issue 21378 has been marked as a duplicate of this issue. ***
Comment 7 akemr 2002-03-15 15:21:38 UTC
*** Issue 21376 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2002-03-25 14:17:25 UTC
verified , support was added.
Comment 9 Rochelle Raccah 2002-03-25 20:20:33 UTC
What about the cleanup task?  Should it be filed as a separate issue?
Comment 10 Quality Engineering 2003-07-01 16:27:31 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 11 Rochelle Raccah 2003-07-09 02:41:08 UTC
The cleanup task was filed as issue 25925 and resolved as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo