Bug 192845 - 4s - ProjectAwareCodeStylePreferences.CSP.<init>
4s - ProjectAwareCodeStylePreferences.CSP.<init>
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.0
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 191079 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-03 12:47 UTC by issaojr
Modified: 2012-12-07 14:19 UTC (History)
37 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (29.73 KB, application/nps)
2010-12-03 12:47 UTC, issaojr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description issaojr 2010-12-03 12:47:44 UTC
Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Linux

User Comments:
psusen: Opening a project from the Recent Projects list on the My NetBeans startup page.

GUEST: the ide was loading

issaojr: slowness during starting up the program

artisan: Open a project



Maximum slowness yet reported was 7396 ms, average is 4812
Comment 1 issaojr 2010-12-03 12:47:49 UTC
Created attachment 103578 [details]
nps snapshot
Comment 2 David Strupl 2011-06-23 14:53:01 UTC
I have evaluated 2 snapshots. In both the problem is that someone is holding ProjectManager.mutex().writeAccess for way too long.

Let's start with report 507261 - the problematic invocation goes from CND. I am reassigning for evaluation.

Please check whether it is really necessary to hold the mutex for 56 seconds.

In editor we are trying to read some project preferences while the user is typing ...

Maybe the problem is in 
org.netbeans.spi.project.support.ant.ProjectGenerator.createProject0()
where it is obtaining the lock. If you agree please assign to projects category.
Comment 3 Jesse Glick 2011-06-27 21:50:44 UTC
(In reply to comment #2)
> Let's start with report 507261 - the problematic invocation goes from CND.

True, but not very relevant. ProjectXMLCatalogReader.projectXmlCombinedSchema (project.ant) is taking 20 sec, which is far outside the normal range; probably just swamped by I/O activity elsewhere. I do not see anything fixable here.

As to the actual freeze in EQ, note that ProjectAwareCodeStylePreferences.CSP.<init> is what is blocking on PM.mutex; postReadRequest does _not_ run asynch in general.
Comment 4 Vladimir Voskresensky 2011-06-28 00:06:24 UTC
I agree with Jesse. The root cause is ProjectAwareCodeStylePreferences.CSP.<init> and I/O is something that always can be slow
Comment 5 Dusan Balek 2012-04-19 12:44:28 UTC
*** Bug 191079 has been marked as a duplicate of this bug. ***
Comment 6 Dusan Balek 2012-12-07 14:19:28 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/72f0063cf498


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo