Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 192814 - IllegalArgumentException: Parameter file was not normalized
IllegalArgumentException: Parameter file was not normalized
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
7.0
All All
: P3 with 1 vote (vote)
: 7.0
Assigned To: Vladimir Kvashin
issues@cnd
:
: 192526 192849 193068 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-02 18:02 UTC by Vladimir Kvashin
Modified: 2011-04-08 08:52 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.86 KB, text/plain)
2010-12-08 10:27 UTC, Vladimir Voskresensky
Details
stacktrace (4.40 KB, text/plain)
2010-12-08 10:33 UTC, Alexander Simon
Details
stacktrace (4.40 KB, text/plain)
2010-12-08 11:09 UTC, Alexander Simon
Details
stacktrace (6.13 KB, text/plain)
2010-12-08 11:39 UTC, Vladimir Voskresensky
Details
stacktrace (4.38 KB, text/plain)
2010-12-08 14:45 UTC, Alexander Simon
Details
stacktrace (2.91 KB, text/plain)
2010-12-08 20:21 UTC, mortennobel
Details
stacktrace (2.30 KB, text/plain)
2010-12-08 20:24 UTC, mortennobel
Details
stacktrace (3.57 KB, text/plain)
2010-12-08 20:30 UTC, mortennobel
Details
stacktrace (2.07 KB, text/plain)
2010-12-22 19:39 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2010-12-02 18:02:43 UTC
A number of exception reports correspond to an issue that has been fixed, see
http://statistics.netbeans.org/analytics/showduplicateslist.do?id=173114

But actually they have different root causes.

I'm filing this issue manually as an umberlla issue for the following reports (grouped below by root causes - each root cause is presented by one source line).


http://statistics.netbeans.org/analytics/exception.do?id=429332
org.netbeans.modules.cnd.makeproject.ui.wizards.SelectModePanel$1.update(SelectModePanel.java:115)

http://statistics.netbeans.org/analytics/exception.do?id=430253
org.netbeans.modules.cnd.makeproject.ui.wizards.SelectBinaryPanelVisual.validBinary(SelectBinaryPanelVisual.java:606)


http://statistics.netbeans.org/analytics/exception.do?id=442787
http://statistics.netbeans.org/analytics/exception.do?id=445023
org.netbeans.modules.cnd.makeproject.ui.SelectExecutablePanel.(SelectExecutablePanel.java:83)


http://statistics.netbeans.org/analytics/exception.do?id=434713
org.netbeans.modules.cnd.qnavigator.navigator.CsmFileModel.buildModel(CsmFileModel.java:104)

http://statistics.netbeans.org/analytics/exception.do?id=434730
org.netbeans.modules.cnd.modelimpl.csm.core.CsmStandaloneFileProviderImpl.onFileRemove(CsmStandaloneFileProviderImpl.java:207)


http://statistics.netbeans.org/analytics/exception.do?id=435808
org.netbeans.modules.cnd.makeproject.api.configurations.Item.getFileObjectImpl(Item.java:391)


http://statistics.netbeans.org/analytics/exception.do?id=435164
http://statistics.netbeans.org/analytics/exception.do?id=438203
http://statistics.netbeans.org/analytics/exception.do?id=438225
http://statistics.netbeans.org/analytics/exception.do?id=431100
http://statistics.netbeans.org/analytics/exception.do?id=436252
org.netbeans.modules.cnd.toolchain.execution.ErrorParser.resolveFile(ErrorParser.java:90)

http://statistics.netbeans.org/analytics/exception.do?id=438001
http://statistics.netbeans.org/analytics/exception.do?id=437992
org.netbeans.modules.cnd.makeproject.api.configurations.Folder.refreshDiskFolder(Folder.java:144)


http://statistics.netbeans.org/analytics/exception.do?id=438998
org.netbeans.modules.cnd.makeproject.ui.wizards.SelectBinaryPanelVisual.updateRoot(SelectBinaryPanelVisual.java:226)


http://statistics.netbeans.org/analytics/exception.do?id=443443
http://statistics.netbeans.org/analytics/exception.do?id=441022
org.netbeans.modules.cnd.discovery.projectimport.ImportProject.makeProject(ImportProject.java:643)

http://statistics.netbeans.org/analytics/exception.do?id=441851
http://statistics.netbeans.org/analytics/exception.do?id=441804
org.netbeans.modules.cnd.discovery.projectimport.ImportProject.makeProject(ImportProject.java:662)
Comment 1 Vladimir Kvashin 2010-12-03 14:58:33 UTC
*** Bug 192849 has been marked as a duplicate of this bug. ***
Comment 2 Exceptions Reporter 2010-12-08 08:57:45 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=174610
Comment 3 Vladimir Voskresensky 2010-12-08 10:27:45 UTC
Created attachment 103726 [details]
stacktrace
Comment 4 Alexander Simon 2010-12-08 10:33:44 UTC
Created attachment 103727 [details]
stacktrace
Comment 5 Alexander Simon 2010-12-08 11:09:44 UTC
Created attachment 103729 [details]
stacktrace
Comment 6 Vladimir Voskresensky 2010-12-08 11:39:47 UTC
Created attachment 103738 [details]
stacktrace
Comment 7 Exceptions Reporter 2010-12-08 11:40:00 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=174610
Comment 8 Exceptions Reporter 2010-12-08 11:42:46 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=174610
Comment 9 Vladimir Kvashin 2010-12-08 12:13:20 UTC
The last case (the stack that goes through CndFileUtils.isExistingFile) should be fixed now
Comment 10 Alexander Simon 2010-12-08 14:45:48 UTC
Created attachment 103743 [details]
stacktrace
Comment 11 mortennobel 2010-12-08 20:21:48 UTC
Created attachment 103760 [details]
stacktrace
Comment 12 mortennobel 2010-12-08 20:24:49 UTC
Created attachment 103761 [details]
stacktrace
Comment 13 mortennobel 2010-12-08 20:30:49 UTC
Created attachment 103762 [details]
stacktrace
Comment 14 Quality Engineering 2010-12-09 06:20:11 UTC
Integrated into 'main-golden', will be available in build *201012090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/05aaf7cf2b6c
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing the last case of #192814 -  IllegalArgumentException: Parameter file was not normalized
Comment 15 Vladimir Kvashin 2010-12-13 12:43:14 UTC
*** Bug 192526 has been marked as a duplicate of this bug. ***
Comment 16 Vladimir Voskresensky 2010-12-16 10:15:51 UTC
*** Bug 193068 has been marked as a duplicate of this bug. ***
Comment 17 javydreamercsw 2010-12-22 19:39:27 UTC
Created attachment 104408 [details]
stacktrace

Ctrl+ click on method name
Comment 18 Vladimir Kvashin 2011-04-07 16:08:58 UTC
fixed in cnd-main
http://hg.netbeans.org/cnd-main/rev/41abfe63371f

All mentioned stacks are fixed.

If a different stack with the same top occurs, a separate issue should be filed, as it's always client who is responsible for normalization.
Comment 19 Quality Engineering 2011-04-08 08:52:38 UTC
Integrated into 'main-golden', will be available in build *201104080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/41abfe63371f
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #192814 - IllegalArgumentException: Parameter file was not normalized


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo