Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 19266 - [JDK1.4] No cells are editable by the keyboard
[JDK1.4] No cells are editable by the keyboard
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: A11Y, JDK_SPECIFIC
: 22586 29530 31406 35986 (view as bug list)
Depends on: 31896
Blocks: 33281 36037
  Show dependency treegraph
 
Reported: 2002-01-10 12:24 UTC by Marian Mirilovic
Modified: 2008-12-22 19:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2002-01-10 12:24:36 UTC
[nb331_dev](20020110), 

- [jdk1.4](91)
	Impossible to change settings level, because after hitting <space> on selected
table cell, focus is transfered back into JTree view and selected node!
This isssue prevent funcionallity : change settings level -> P4/JDK_1.4

- [jdk1.3.1](02)
	You need push <space> twice to expand combobox, only one hitting doesn't expand
combobox.
Comment 1 Jan Chalupa 2002-01-11 14:03:39 UTC
Target milestone -> 3.4
Comment 2 Jan Chalupa 2002-01-11 14:07:46 UTC
Target milestone -> 3.4
Comment 3 Jan Chalupa 2002-01-11 14:08:47 UTC
Target milestone -> 3.4
Comment 4 Jan Chalupa 2002-01-11 14:11:34 UTC
Target milestone -> 3.4
Comment 5 Marian Mirilovic 2002-01-16 13:11:10 UTC
Rise priority to P3, Jano please resolve this issue ASAP. 
Thanks in advance.
Comment 6 jrojcek 2002-06-26 14:58:02 UTC
Correct behavior is that one key press expands combo box.
Comment 7 Peter Zavadsky 2002-07-04 15:31:48 UTC
Assiginng to owner.
Comment 8 Jiri Rechtacek 2002-07-04 16:31:48 UTC
it's in TreeTableView, I reassigning to akemr, Sorry Alesi :-(
Comment 9 Peter Zavadsky 2002-07-08 08:53:09 UTC
*** Issue 22586 has been marked as a duplicate of this issue. ***
Comment 10 Marek Grummich 2002-07-22 11:13:31 UTC
Set target milestone to TBD
Comment 11 Marek Grummich 2002-07-22 11:17:03 UTC
Set target milestone to TBD
Comment 12 Jan Becicka 2002-10-16 14:58:47 UTC
Import Management Tool is not fully accessible 
due to this bug. See issue 25410.
Comment 13 Jiri Rechtacek 2002-12-13 09:51:39 UTC
*** Issue 29530 has been marked as a duplicate of this issue. ***
Comment 14 Jiri Rechtacek 2002-12-13 09:53:01 UTC
jesse's comment from issue 29530:
[dev dec 09] Open Setup Wizard and go the Modules
panel. Try navigating thru the modules with the
arrow keys - that works fine. But there is no
apparent way to turn modules on or off using the
KB here. You can tab into or out of value cells,
but when you are in them, how to change them? F2
(normal in JTable) does not work. SPACE (normal in
property sheet) doesn't either.

Comment 15 Jiri Rechtacek 2003-02-19 14:25:45 UTC
investigate keyboard navigation and focus behavior
Comment 16 Jiri Rechtacek 2003-02-25 15:12:41 UTC
*** Issue 31406 has been marked as a duplicate of this issue. ***
Comment 17 Marian Mirilovic 2003-05-15 09:34:07 UTC
What's the status of this issue ?
Comment 18 pzajac 2003-09-10 12:46:01 UTC
*** Issue 35986 has been marked as a duplicate of this issue. ***
Comment 19 _ tboudreau 2003-11-22 22:37:54 UTC
Taking this issue - it's fixed on the property panel rewrite branch -
I ported a bunch of stuff from the property sheet table for making
keyboard behavior sane.
Comment 20 _ tboudreau 2003-12-09 09:36:36 UTC
Property panel rewrite branch merged.
Comment 21 Marian Mirilovic 2004-02-24 12:05:31 UTC
verified in [nb_dev](200402221900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo