Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 192628 - CC blocked by NexusRepositoryIndexer
CC blocked by NexusRepositoryIndexer
Status: RESOLVED DUPLICATE of bug 200263
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P3 (vote)
: 7.2
Assigned To: Milos Kleint
issues@projects
: PERFORMANCE
Depends on:
Blocks: 179727
  Show dependency treegraph
 
Reported: 2010-11-29 10:43 UTC by Jaroslav Tulach
Modified: 2012-03-26 23:05 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2010-11-29 10:43:21 UTC
The slowness report
http://statistics.netbeans.org/exceptions/exception.do?id=445497
seems to indicate that the code completion is blocked by initialization of 
org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext()

As the content of the indexing context is likely to be needed whenever one edits a pom.xml I suggest to preload it as soon as the pom.xml is opened in editor or when a maven project is openened.

At minimum (to lower the priority) the maven CC support needs to warn the user that it is about to perform a lengthy operation via http://bits.netbeans.org/dev/javadoc/org-netbeans-modules-editor-completion/org/netbeans/spi/editor/completion/CompletionResultSet.html#setWaitText(java.lang.String
Comment 1 Jesse Glick 2010-11-29 21:28:26 UTC
Any reports in 7.0? Tonda did some related fix recently I think.
Comment 2 Jaroslav Tulach 2010-11-29 22:24:36 UTC
Should you look at report 445497 closely, you'd find out that it is from 7.0Beta.
Comment 3 Antonin Nebuzelsky 2011-03-17 11:59:13 UTC
> At minimum (to lower the priority) the maven CC support
> needs to warn the user that it is about to perform a lengthy operation.

Decreasing to P3. The warning to the user about XML CC in general is implemented in issue 192625.
Comment 4 Milos Kleint 2012-03-20 15:50:06 UTC
this should have been fixed lately as indexing is triggered by indexer queries, but the queries no longer block on completion of the indexing, instead we notify the user that indexing takes place only. (and return partial results from indexes already ready for consumption)
Comment 5 Jesse Glick 2012-03-26 23:05:23 UTC

*** This bug has been marked as a duplicate of bug 200263 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo