Bug 192478 - Hang in AbstractModel.startTransaction
Hang in AbstractModel.startTransaction
Status: RESOLVED DUPLICATE of bug 207463
Product: projects
Classification: Unclassified
Component: Maven
7.0
PC Windows 7
: P3 (vote)
: 7.2
Assigned To: Milos Kleint
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-25 15:17 UTC by dao
Modified: 2012-03-26 23:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Netbeans ThreadDump (29.99 KB, text/plain)
2010-11-25 15:17 UTC, dao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dao 2010-11-25 15:17:50 UTC
Created attachment 103330 [details]
Netbeans ThreadDump

1- Created a JavaEE6 maven project.
2- Open project properties "Framework tab".
3- Select "Java Server Faces" and components lib "primefaces"
4- Save project properties.
The dialog windows "writing project properties" hanged and never closed till I've kill the process.
Comment 1 Jesse Glick 2010-11-29 20:14:14 UTC
I think dupe of some open issue.
Comment 2 Milos Kleint 2012-03-20 15:57:43 UTC
the relevant code is no longer present in the current codebase:
"AWT-EventQueue-1" prio=6 tid=0x0a994000 nid=0x1c64 waiting for monitor entry [0x0b98d000]
   java.lang.Thread.State: BLOCKED (on object monitor)
	at org.netbeans.modules.xml.xam.AbstractModel.rollbackTransaction(AbstractModel.java:434)
	- waiting to lock <0x1e1a80b0> (a org.netbeans.modules.maven.model.pom.impl.POMModelImpl)
	at org.netbeans.modules.maven.customizer.CustomizerProviderImpl$OptionListener$1.run(CustomizerProviderImpl.java:285)

The pom file is now saved in non-awt thread and avoids a lengthy xam transaction (and doesn't need to be rollbacked now).
Comment 3 Jesse Glick 2012-03-26 23:06:36 UTC

*** This bug has been marked as a duplicate of bug 207463 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo