Bug 192264 - After update to 6.9.1 # 2, identation is a mess!!!
After update to 6.9.1 # 2, identation is a mess!!!
Status: RESOLVED DUPLICATE of bug 192098
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows 7 x64
: P2 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-22 11:14 UTC by ecerichter
Modified: 2010-11-22 11:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ecerichter 2010-11-22 11:14:47 UTC
After update to 6.9.1 patch 2, identation is completely lost. For me, this is a major block, so I've rated this initially as P2.

I can't stand working with the editor anymore, and had to completely uninstall NetBeans 6.9.1 patch 2 and re-install NetBeans 6.9.1 then disable the auto update feature.

Example of the issue:

Normally, I would created idented blocks like this:

public void doSomething() {
  for(int i = 0; i < 100; i++) {
    System.out.println(i);
  }
}

With the new editor, if I don't ajust manually the code, I get:

public void doSomething() {
  for(int i = 0; i < 100; i++) {
    System.out.println(i);
}
}

This is even worse when you think in splitting strings, or complex identation structures.

I believe it's related to the fix for the bug 188112, but this is just a guess.

Regards,

Edson.
Comment 1 Dusan Balek 2010-11-22 11:40:12 UTC

*** This bug has been marked as a duplicate of bug 192098 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo