Bug 192044 - String value is not shown in Variables by default
String value is not shown in Variables by default
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
7.0
All All
: P1 with 1 vote (vote)
: 7.0
Assigned To: Egor Ushakov
issues@cnd
: 70_HR_FIX
: 197086 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-17 10:12 UTC by Alexander Pepin
Modified: 2011-03-31 13:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2010-11-17 10:12:46 UTC
This is a regression introduced after switching to a new common debugger.
Previously user can see std::string value in Variables and Watches without expanding the variable e.g.:
customerName     "Ann"

now it's shown as:  
customerName     {...}
Comment 1 Alexander Pepin 2010-12-06 17:15:48 UTC
Now a user has to expand two nodes to see the string value:
[-] customerName	        {...}	        string	
    npos	                4294967295	const size_t	
    [-] _M_dataplus	        {...}           std::basic_string<char,...	
         std::allocator<char>	{...}	        std::allocator<char>	
         _M_p                   0x8dc1104 "fff"	char *
Comment 2 soldatov 2011-03-15 10:32:58 UTC
On elif some test is marked as "Known Failure"
Comment 3 Egor Ushakov 2011-03-21 13:56:06 UTC
fixed for string values in trunk:
http://hg.netbeans.org/cnd-main/rev/4063e2d214bb
Comment 4 Egor Ushakov 2011-03-21 14:14:28 UTC
extra fix:
http://hg.netbeans.org/cnd-main/rev/44b6f2733df6
Comment 5 Alexander Pepin 2011-03-21 16:42:28 UTC
verified in dev build #5002,
please push the fix into release70 branch.
Comment 6 Andrew Krasny 2011-03-21 17:03:41 UTC
Egor, there are several NOI18N issues.... Need one more fix with NOI18N added...
Comment 7 Egor Ushakov 2011-03-22 08:00:14 UTC
i18n fix: http://hg.netbeans.org/cnd-main?cmd=changeset;node=c569cca890a1
Comment 8 Egor Ushakov 2011-03-22 08:05:03 UTC
another important fix: http://hg.netbeans.org/cnd-main?cmd=changeset;node=59ddea0c7a97
Comment 9 Quality Engineering 2011-03-22 09:56:57 UTC
Integrated into 'main-golden', will be available in build *201103220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4063e2d214bb
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #192044 (String value is not shown in Variables by default)
Comment 10 Egor Ushakov 2011-03-22 11:48:41 UTC
integrated into release70:
http://hg.netbeans.org/releases/rev/151003952033
Comment 11 Alexander Pepin 2011-03-23 10:32:28 UTC
verified in RC1 build 20110323.
Comment 12 Alexander Pepin 2011-03-28 09:46:05 UTC
*** Bug 197086 has been marked as a duplicate of this bug. ***
Comment 13 Alexander Pepin 2011-03-28 09:48:43 UTC
I'm reopening the bug, please provide an additional fix for the testcase from bug #197086
Comment 14 Egor Ushakov 2011-03-28 12:39:58 UTC
fixed in trunk:
http://hg.netbeans.org/cnd-main/rev/7797d03f77c7
Comment 15 Alexander Pepin 2011-03-28 14:56:08 UTC
Verified in dev build #5042
Comment 16 Egor Ushakov 2011-03-28 15:06:42 UTC
integrated into release70:
http://hg.netbeans.org/releases/rev/8f89c805730e
Comment 17 Quality Engineering 2011-03-29 08:42:01 UTC
Integrated into 'main-golden', will be available in build *201103290400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7797d03f77c7
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #192044 (String value is not shown in Variables by default) - fix for std::string
Comment 18 Alexander Pepin 2011-03-31 13:25:55 UTC
Verified in RC2 build 20110331


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo