Bug 191959 - cannot create new project with (Zend) framework
cannot create new project with (Zend) framework
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Zend
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: pgebauer
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-15 10:47 UTC by dgo
Modified: 2010-11-15 15:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dgo 2010-11-15 10:47:36 UTC
hi,

I don't know why, but since a couple of days, I can not create a new project with Zend Framework support...

When creating a new project (File > New Project) and completing the wizard as I usually do, I am no longer able to select any PHP Framework at the end... I can not check the checkbox.

The whole Zend support does work in Netbeans though...
Zend Tools function correctly etc. etc.

As there has been no update of the software, I am pretty sure that I must have done something wrong... But what ? And where should I start looking ?

I tried reinstalling netbeans, but that did not help.

I am working on Ubuntu 10.04 (64bit).
I tried this with different versions of ZF (1.9.6, 1.10.2, 1.10.6 & 1.10.8) but nothing changed.

Any clues on this ?

Thanks a lot in advance !
dGo
Comment 1 Filip Zamboj 2010-11-15 11:57:07 UTC
what netbeans version is it? thanks
Comment 2 dgo 2010-11-15 12:40:28 UTC
(In reply to comment #1)
> what netbeans version is it? thanks

6.9.1...
thanks,
Comment 3 dgo 2010-11-15 12:54:23 UTC
ok...
a little further into the rabbit hole...

just noticed that the problem has nothing to do with Zend Framework...
but, it seems that I am no longer able to check some checkboxes in Netbeans.

for instance, in Tools > Plugins > Available Plugins, I can not check the checkboxes either.
But, when I select a line and hit the spacebar, I am able to select the plugin...

This does not work in the new project wizard...

The strange thing being that this is not the case with all the checkboxes.
Could this be some kind of Gnome bug ?
Or a Java GUI-library bug ?
Comment 4 dgo 2010-11-15 12:59:29 UTC
the same bug is already filed here:
http://stackoverflow.com/questions/4089036/cannot-select-framework-to-use-in-new-web-application-using-netbeans-on-ubuntu

so I guess this is an Ubuntu bug...
but all suggestions are welcome...

in the meantime, I'm going to do a clean install... see if that works out
Comment 5 Filip Zamboj 2010-11-15 14:16:17 UTC
the bug you sent is about Java WEB. 

well, I have no idea to be honest and I have never seen such a report yet. Would you check with latest development build? I am sure it works for me.
Comment 6 Filip Zamboj 2010-11-15 14:17:38 UTC
here you can get new dev build: http://bertram.netbeans.org/hudson/job/PHP-Build/?
Comment 7 dgo 2010-11-15 14:48:10 UTC
(In reply to comment #6)
> here you can get new dev build:
> http://bertram.netbeans.org/hudson/job/PHP-Build/?

Hi Filip,

Just gave that a try... but still encountering the same problem...
which is quite logical if it is a Java Web bug...

Is there some way to use an alternate Java package or something ?

thanks,
dGo
Comment 8 Filip Zamboj 2010-11-15 15:46:14 UTC
I don't really get it. Zend Framework is php framework written in php. there is no way java web will contain zend framework - this would be a bug. You need to create php project
Comment 9 dgo 2010-11-15 15:53:51 UTC
(In reply to comment #8)
> I don't really get it. Zend Framework is php framework written in php. there is
> no way java web will contain zend framework - this would be a bug. You need to
> create php project

hi Filip,

The problem is not the framework, it was that I could not attach the framework to the project.

I found a solution...
For the other users that have this problem... Here is what I did.
(partial solution found here :
http://www.edmondscommerce.co.uk/ubuntu/ubuntu-10-04-sun-java/)

1. install sun-java
      sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"
      sudo apt-get update
      sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

2. gksudo gedit /usr/local/netbeans-6.9.1/etc/netbeans.conf
      set netbeans_jdkhome="/usr/lib/jvm/java-6-sun"
      (check your paths !)

3. save, close and start Netbeans...

et voilà...
it worked again !
Comment 10 Filip Zamboj 2010-11-15 15:59:40 UTC
glad to hear it works


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo