Bug 191918 - Cannot build/run projects due to path trunctation error
Cannot build/run projects due to path trunctation error
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant
6.x
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Milos Kleint
issues@projects
: USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-13 17:53 UTC by brikbot
Modified: 2013-08-29 13:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brikbot 2010-11-13 17:53:00 UTC
Product Version = NetBeans IDE 6.9.1 (Build 201011082200)
Operating System = Windows 7 version 6.1 running on x64-x86
Java; VM; Vendor = 1.6.0_18
Runtime = Java HotSpot(TM) Client VM 16.0-b13

Projects will not build or run due to an error, cause is not understood.  It would appear the that path is being truncated at the "@" in the user path (user name is "Paul F@!nt Marshall").  This is not an issue of the project that is being attempted to be built or run, as there are no issues on other machines or other user profiles on the same machine, so it seems to be a NetBeans issue.  This was not an issue until only a couple days ago.  Similar behavior has been seen on a path that had an apostrophy "'" in the path: example is "Alec's Projects".  The path would truncate at "Alec" and fail.

Example error output:
Adding reference: ant.PropertyHelper
Detected Java version: 1.6 in: C:\Program Files (x86)\Java\JDK\jre
Detected OS: Windows 7
Adding reference: ant.ComponentHelper
Trying to override old definition of task java
 +Datatype java org.apache.tools.ant.module.bridge.impl.ForkedJavaOverride
java.io.FileNotFoundException: C:\Users\Paul F@ (The system cannot find the file specified)
        at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:318)
        at org.apache.tools.ant.helper.ProjectHelper2.parseUnknownElement(ProjectHelper2.java:130)
        at org.apache.tools.ant.module.bridge.impl.NbAntlib.process(NbAntlib.java:76)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.addCustomDefs(BridgeImpl.java:369)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:199)
        at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:539)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:154)
Caused by: java.io.FileNotFoundException: C:\Users\Paul F@ (The system cannot find the file specified)
        at java.io.RandomAccessFile.open(Native Method)
        at java.io.RandomAccessFile.<init>(RandomAccessFile.java:212)
        at org.apache.tools.zip.ZipFile.<init>(ZipFile.java:182)
        at org.apache.tools.zip.ZipFile.<init>(ZipFile.java:148)
        at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:274)
        ... 6 more
Comment 1 Jesse Glick 2010-11-19 14:49:11 UTC
It is likely that the Ant core is misinterpreting the '!' in the pathname as the separator in a jar-protocol URL. Apostrophes are also likely to cause problems for build scripts which need to represent absolute file paths, as they are subject to misinterpretation as shell quotes, especially when launching subprocesses.

Avoid placing projects, or your NetBeans installation or user directory, under paths which use punctuation characters (other than '.', '_', or '-') to avoid this kind of problem.
Comment 2 Milos Kleint 2012-10-30 07:06:22 UTC
most likely ant issue https://issues.apache.org/bugzilla/show_bug.cgi?id=50007 is related
Comment 3 Milos Kleint 2013-08-29 13:39:35 UTC
ant's 50007 issue comment mentions that the recent versions of Ant (that we ship) should be able to handle ! character as long as it's not the last char in the directory name.

closing as fixed (as we likely fixed this by upgrading ant),
please verify and reopen if still not working


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo