Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 191843 - [70cat] New files created outside IDE are not listed
[70cat] New files created outside IDE are not listed
Status: RESOLVED DUPLICATE of bug 190462
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Linux
: P1 (vote)
: TBD
Assigned To: Michel Graciano
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 13:03 UTC by Michel Graciano
Modified: 2010-11-11 16:11 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample project.xml (16.17 KB, text/xml)
2010-11-11 15:52 UTC, Michel Graciano
Details
Fixed project.xml (16.48 KB, text/xml)
2010-11-11 16:11 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2010-11-11 13:03:38 UTC
[ BUILD # : 542c809fd5ba ]
[ JDK VERSION : 1.6.20 ]

I have a free form project and new files created outside the IDE are not listed
until I restart it or for example, use CVS Show Changes which force the folder
rescan. The files are not listed even at Projects as well Files view.

Product Version: NetBeans IDE Dev (Build 101109-542c809fd5ba)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
System: Linux version 2.6.31-22-generic-pae running on i386; UTF-8; pt_BR (nb)

Ubuntu 9.10
Comment 1 Petr Nejedly 2010-11-11 15:44:06 UTC

*** This bug has been marked as a duplicate of bug 190462 ***
Comment 2 Michel Graciano 2010-11-11 15:50:22 UTC
In the truth, the files I have created are in folders present in source roots. I don't think it is dup of that. The file is included at a folder with style="tree" but I think it is not a problem. I will attach my project.xml soon.
Comment 3 Michel Graciano 2010-11-11 15:52:09 UTC
Created attachment 102917 [details]
Sample project.xml

The folder I have added a new file was src/jasper. I will reopen it for evaluation.
Comment 4 Petr Nejedly 2010-11-11 16:09:20 UTC
Then it must be a different problem.
Can I see your ide.log?
Comment 5 Michel Graciano 2010-11-11 16:10:47 UTC
It is really a dup of that. I was able to fix my problem now. I updated our project.xml, which I will attach soon, just adding it to <folders>...</folders> as subelement. Looks like the events are not fired to folders published just as views. Sorry for misunderstanding, but now I figure out the problem.

*** This bug has been marked as a duplicate of bug 190462 ***
Comment 6 Michel Graciano 2010-11-11 16:11:51 UTC
Created attachment 102919 [details]
Fixed project.xml

Well, I still consider it a issue but now for sure it is a dup of 190462.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo