Bug 191779 - [HeapWalker] Detect heap dump caused by OOME and indicate which thread is throwing OOME
[HeapWalker] Detect heap dump caused by OOME and indicate which thread is thr...
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 08:38 UTC by Tomas Hurka
Modified: 2010-11-17 07:08 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2010-11-10 08:38:06 UTC
Add support for JDK enhancement CR 6765718 "Indicate which thread throwing OOME when generating the heap dump at OOME".
Comment 1 Tomas Hurka 2010-11-10 09:00:42 UTC
Fixed in profiler-main


changeset:   181606:32a849f9d9aa
user:        Tomas Hurka <thurka@netbeans.org>
date:        Wed Nov 10 09:59:09 2010 +0100
summary:     issue #191779, Detect heap dump caused by OOME and indicate which thread is throwing OOME
Comment 2 Quality Engineering 2010-11-17 07:08:24 UTC
Integrated into 'main-golden', will be available in build *201011170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/32a849f9d9aa
User: Tomas Hurka <thurka@netbeans.org>
Log: issue #191779, Detect heap dump caused by OOME and indicate which thread is throwing OOME


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo