Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 191657 - Modules enabled if install as root / update as regular user
Modules enabled if install as root / update as regular user
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.0
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
au-issues
:
: 119658 191643 (view as bug list)
Depends on: 200978
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 08:08 UTC by Marian Mirilovic
Modified: 2011-08-15 22:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2010-11-05 08:08:12 UTC
See issue 191300, if you repeat the same scenario for install as root / update as user, you will end up with enabled all updated features (even if you haven't used it before), which is wrong.

Used Full IDE.
Comment 1 Jaroslav Tulach 2010-11-05 09:19:07 UTC
*** Bug 191643 has been marked as a duplicate of this bug. ***
Comment 2 Jaroslav Tulach 2010-11-05 09:23:23 UTC
I guess the best fix would be to not update module that are not enabled.
Comment 3 Jaroslav Tulach 2010-11-05 09:27:31 UTC
*** Bug 119658 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2010-12-22 14:24:53 UTC
ergonomics#d12a45fbf91f
Comment 5 Quality Engineering 2010-12-29 07:08:59 UTC
Integrated into 'main-golden', will be available in build *201012290001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d12a45fbf91f
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #191657: Offer only enabled modules for update


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo