Bug 191635 - IndexOutOfBoundsException: Index: 0, Size: 0
IndexOutOfBoundsException: Index: 0, Size: 0
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
All All
: P1 (vote)
: 7.0
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
:
: 192994 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-04 11:59 UTC by mithridates
Modified: 2010-12-07 16:15 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.41 KB, text/plain)
2010-11-04 11:59 UTC, mithridates
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mithridates 2010-11-04 11:59:12 UTC
This issue was reported manually by mithridates.
It already has 7 duplicates 


Build: NetBeans IDE Dev (Build 201011040000)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Linux

User Comments:
mithridates: Tried to do a subversion commit on the "Web Pages"-node of a Webproject

mbiastoch: import of new file to svn




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
   at java.util.ArrayList.RangeCheck(ArrayList.java:547)
   at java.util.ArrayList.get(ArrayList.java:322)
   at org.netbeans.modules.bugtracking.vcs.SvnHookImpl.afterCommit(SvnHookImpl.java:80)
   at org.netbeans.modules.subversion.ui.commit.CommitAction.afterCommit(CommitAction.java:782)
   at org.netbeans.modules.subversion.ui.commit.CommitAction.performCommit(CommitAction.java:693)
   at org.netbeans.modules.subversion.ui.commit.CommitAction.performCommit(CommitAction.java:545)
Comment 1 mithridates 2010-11-04 11:59:16 UTC
Created attachment 102797 [details]
stacktrace
Comment 2 Tomas Stupka 2010-11-10 09:01:59 UTC
fixed in core-main
Comment 3 Tomas Stupka 2010-11-10 09:03:21 UTC
too many duplicates, highly visible -> raising priority
Comment 4 Marian Mirilovic 2010-11-10 09:56:31 UTC
I agree with integration to NB 7.0 Beta.
Comment 5 Tomas Stupka 2010-11-10 12:53:23 UTC
integrated - releases #d08b2b20ff0d
Comment 6 Quality Engineering 2010-11-11 06:11:30 UTC
Integrated into 'main-golden', will be available in build *201011110000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8ae83e94c7cf
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #191635 - IndexOutOfBoundsException: Index: 0, Size: 0
Comment 7 Tomas Stupka 2010-12-07 16:15:35 UTC
*** Bug 192994 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo