Bug 191413 - Deadlock while double-clicking on a component that extends JPanel
Deadlock while double-clicking on a component that extends JPanel
Status: RESOLVED DUPLICATE of bug 187697
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 16:32 UTC by matteodg
Modified: 2010-10-27 18:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump of blocked NB (20.45 KB, text/plain)
2010-10-27 16:32 UTC, matteodg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matteodg 2010-10-27 16:32:41 UTC
Created attachment 102685 [details]
Thread dump of blocked NB

In NetBeans 6.9.1 I double-clicked on a component that extends JPanel and I got stuck on a deadlock between these two threads:
- AWT thread, name is "AWT-EventQueue-1"
- a RequestProcessor thread, name is "GUI Builder"

Attached there is thread dump saved with JVisualVM.
Comment 1 Jan Stola 2010-10-27 18:00:54 UTC
This is a temporary problem of JDK. You should use either JDK 6 update 20 or JDK 6 update 23 (there is a bug in updates 21 and 22).

*** This bug has been marked as a duplicate of bug 187697 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo