Bug 191300 - Form disabled after upgrade from 6.9.1 to patch2
Form disabled after upgrade from 6.9.1 to patch2
Status: RESOLVED INCOMPLETE
Product: javame
Classification: Unclassified
Component: CDC pack
6.x
PC Linux
: P1 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
69patch2-fixed
: ERGONOMICS, REGRESSION
: 191302 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-25 09:48 UTC by Jiri Kovalsky
Modified: 2011-02-28 10:25 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of not recognized .form files. (16.44 KB, image/png)
2010-10-25 09:48 UTC, Jiri Kovalsky
Details
Screenshot of not recognized .form files as of October 27, 2010. (16.31 KB, image/png)
2010-10-27 12:12 UTC, Jiri Kovalsky
Details
Messages.log from the IDE session after updating 6.9 Patch 2. (43.93 KB, text/plain)
2010-10-27 12:13 UTC, Jiri Kovalsky
Details
Proper version of Auto Update's updater (207.79 KB, application/octet-stream)
2010-11-02 10:44 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2010-10-25 09:48:01 UTC
Created attachment 102606 [details]
Screenshot of not recognized .form files.

Product Version: NetBeans IDE 6.9 (Build 201007282301)
Java: 1.6.0_22; Java HotSpot(TM) Client VM 17.1-b03
System: Linux version 2.6.31-22-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/cesilko/.netbeans/6.9

Description:
============
After updating clean NetBeans IDE 6.9 install with Update 2 and generating Anagram Game sample project GUI form data nodes showed up broken down to separate .java filenodes and not recognised .form filenodes - see attached scroonshot. This is a serious regression which should be fixed as soon as possible although it's not easily reproducible.

What I exactly did:
===================
1. I unzipped Java distribution of NetBeans IDE 6.9 build #201007282301.
2. Invoked "Tools > Plugins" and switched to "Settings" tab.
3. Changed URL of NetBeans UC to staging area [1]. Pressed "OK".
4. Switched to "Updates" tab, clicked "Reload Catalog", selected all updates and clicked "Update" button.
5. Followed the process to install all updates and immediately restarted IDE.
6. Then I generated new Anagram Game sample project via "File > New Project...".
7. Once the project was opened I first expanded "com.toy.anagrams.lib" folder and then "com.toy.anagrams.ui".

[1] http://updates.netbeans.org/netbeans/updates/6.9/uc/final/stable/catalog_stage.xml.gz
Comment 1 Marian Mirilovic 2010-10-25 10:04:18 UTC
see also issue 191302 ... activated/deactivated features right after update
Comment 2 Jaroslav Tulach 2010-10-25 10:58:12 UTC
Insert additional step:

3a. Choose "Force install into shared directories"

and the problem will be gone.
Comment 3 Marian Mirilovic 2010-10-25 11:00:15 UTC
(In reply to comment #2)
> Insert additional step:
> 3a. Choose "Force install into shared directories"
> and the problem will be gone.

Ok, so we have workaround for one case. What about root/user test case (install by root, update by regular user ?
Comment 4 Jaroslav Tulach 2010-10-25 11:11:05 UTC
Opps, I guess the workaround does not work either. In spite the module JARs are put into shared locations, their appropriate config/Modules/*.xml files are still in user directory.
Comment 5 Jaroslav Tulach 2010-10-25 12:39:27 UTC
This problem may be connected to bug 155991.
Comment 6 Filip Zamboj 2010-10-25 15:59:05 UTC
i didn't reproduce this issue (and BUG 191300) when upgrading 6.8 with default
update center. Features activation was ok, java forms were ok as well. no
failure.
Comment 7 Jaroslav Tulach 2010-10-26 14:50:43 UTC
OK, if this is really supposed to be a regression in 6.8, then another suspicious change set is the one for bug 113341. I am not yet sure, but for some reason "mobility.licensing" module gets loaded even if there is no config file in userdir to trigger it on (and there is config file to disable the module in ergonomics cluster). I suspect this is result of changes to address bug 113341.
Comment 8 Jaroslav Tulach 2010-10-26 15:43:59 UTC
There is one (" j2me.cdc.platform.ojec") or few more new modules in the distribution. This module turn on part of Java support due to its dependencies.

These modules were not known of the ide.ergonomics module at the time of 6.9 or 6.9.1 release, but ergonomics system needs to know about them.

The fix is simple, just rebuild ide.ergonomics, increase the version of that module and  the system shall behave in better way.

Lesson to learn. Next time we add a module in a patch set, let's also rebuild and ublish ide.ergonomics module.

I increased the version in releases#73c811580dae. We need new build and new UC catalog to verify whether this helps the problems to go away or not.
Comment 9 Marian Mirilovic 2010-10-26 15:52:01 UTC
Ok, I started the build just recently ...
Comment 10 Jaroslav Tulach 2010-10-27 09:30:34 UTC
OK, with recent build the behavior is better. Just perform the update and then remove $userdir/config/Modules directory. Then the system starts in the proper ergonomics mode.

I need to fix autoupdate to not create files in $userdir/config/Modules however.
Comment 11 Jaroslav Tulach 2010-10-27 09:30:58 UTC
*** Bug 191302 has been marked as a duplicate of this bug. ***
Comment 12 Jaroslav Tulach 2010-10-27 10:54:06 UTC
I think I have a patch for autoupdate to behave in better way. It deals with all updates except the new file. Petr, could you make


ud/config/Modules/org-netbeans-modules-j2me-cdc-project-ojec.xml
ud/config/Modules/org-netbeans-modules-j2me-cdc-platform-ojec.xml

eager? If so, then we have a fix.
Comment 13 Jiri Kovalsky 2010-10-27 12:12:08 UTC
Created attachment 102676 [details]
Screenshot of not recognized .form files as of October 27, 2010.

Just tried it with the latest update built today and it still does not recognize *.form files - see attached screenshot. I am also going to attach my messages.log file.
Comment 14 Jiri Kovalsky 2010-10-27 12:13:39 UTC
Created attachment 102678 [details]
Messages.log from the IDE session after updating 6.9 Patch 2.
Comment 15 Jaroslav Tulach 2010-10-27 14:21:00 UTC
Fxied as 5b50cbb90054 both in core-main as well as release692 branch. Now it is up to Petr to turn the two modules into eager ones.
Comment 16 Quality Engineering 2010-10-28 02:53:36 UTC
Integrated into 'main-golden', will be available in build *201010280000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/48465908e367
User: psuchomel@netbeans.org
Log: Partial fix for #191300, making modules eager to make ergonimcs's life easier
Comment 17 Petr Blaha 2010-10-29 07:07:29 UTC
Petr, it's fixed http://hg.netbeans.org/releases/rev/e930dbd041b1 
Isn't it ?
Comment 18 Marian Mirilovic 2010-10-29 07:13:10 UTC
previous comment was written by me...
Comment 19 Marian Mirilovic 2010-11-01 10:40:51 UTC
Still doesn't work !!! tested with catalog built on 29th of October, so all fixes are there.
Comment 20 Jaroslav Tulach 2010-11-02 10:44:10 UTC
Created attachment 102755 [details]
Proper version of Auto  Update's updater

OK, looks like there are two mistakes. First of all, before any update happens, we need to update the AutoUpdate itself. I am not sure how that is done, but I guess increasing spec version of autoupdate.services shall do the trick. I have forgotten to do that last time. Fixed in: 27365b0f4a20#release692

I am not sure how to test the automatic behavior. I am attaching my NBM for manual testing:
1. start empty 6.9.1
2. download the AU NBM and install it manually
3. change the update center to the staging location
4. do update

Things are still broken, but I attribute that to mobility. When reproducing the above scenario I can see following files being created in the user directory:


$ find ud/config/Modules
ud/config/Modules
ud/config/Modules/org-netbeans-api-mobility.xml
ud/config/Modules/org-netbeans-modules-mobility-project-bridge.xml
ud/config/Modules/org-netbeans-modules-java-source.xml
ud/config/Modules/org-apache-tools-ant-module.xml
ud/config/Modules/org-netbeans-modules-mobility-licensing.xml
ud/config/Modules/org-netbeans-modules-j2me-cdc-platform.xml
ud/config/Modules/org-netbeans-modules-j2me-cdc-project-execui.xml
ud/config/Modules/org-netbeans-modules-mobility-project.xml
ud/config/Modules/org-netbeans-modules-java-source-ant.xml
ud/config/Modules/org-netbeans-modules-mobility-cldcplatform.xml
ud/config/Modules/org-netbeans-modules-mobility-antext.xml
ud/config/Modules/org-netbeans-modules-j2me-cdc-project.xml

I suspect one of these is a new module and is not annotated as eager. Petr?
Comment 21 Jaroslav Tulach 2010-11-02 16:54:32 UTC
I still see:
$ cat netbeans/mobility/config/Modules/org-netbeans-modules-j2me-cdc-project-ojec.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE module PUBLIC "-//NetBeans//DTD Module Status 1.0//EN"
                        "http://www.netbeans.org/dtds/module-status-1_0.dtd">
<module name="org.netbeans.modules.j2me.cdc.project.ojec">
    <param name="autoload">false</param>
    <param name="eager">false</param>
    <param name="enabled">true</param>
    <param name="jar">modules/org-netbeans-modules-j2me-cdc-project-ojec.jar</param>
    <param name="reloadable">false</param>
</module>


That module is supposed to be eager. Petr, maybe you have forgotten to pump the spec version number and thus the latest version of the module is not available on the update center. Right, Robert?

Btw. manually  changing the 
netbeans/mobility/config/Modules/org-netbeans-modules-j2me-cdc-project-ojec.xml
netbeans/mobility/config/Modules/org-netbeans-modules-j2me-cdc-platform-ojec.xml
into eager modules solves our problems.
Comment 22 Petr Suchomel 2010-11-03 10:14:34 UTC
Jardo, this is weird? Were the right modules uploaded? http://hg.netbeans.org/releases/rev/48465908e367 This also first version of modules, not previous version existed.
Comment 23 Jaroslav Tulach 2010-11-03 12:48:55 UTC
Indeed, it is weird. I you look at
http://dlc.sun.com.edgesuite.net/netbeans/updates/6.9/uc/final/stable/_staging_/patch2/mobility/org-netbeans-modules-j2me-cdc-platform-ojec.nbm
you'll find out that it contains wrong config/Modules/*.xml file. Please make sure the correct nbm file is uploaded.
Comment 24 rnovak 2010-11-03 15:58:00 UTC
The latest version of Patch2 modules is also available at bits.netbeans.org:
http://bits.netbeans.org/netbeans/6.9.2/fixes/latest/uc/
Comment 25 Jaroslav Tulach 2010-11-03 17:37:01 UTC
OK. I did following:

1. I unzipped netbeans-6.9.1-201007282301-java.zip
2. Invoked "Tools > Plugins" and switched to "Settings" tab.
3. Changed URL of NetBeans UC to staging area [1]. Pressed "OK".

3.a downloaded the autoupdate.services NBM
http://netbeans.org/bugzilla/attachment.cgi?id=102755
3.b selected downloaded
3.c added the autoupdate.services NBM
3.d installed it and restarted the ide
3.e went to Tools/Options

4. Switched to "Updates" tab, clicked "Reload Catalog", selected all updates
and clicked "Update" button.
5. Followed the process to install all updates and immediately restarted IDE.
6. Then I generated opened existing desktop app project
7. The .form files were correctly recognized and opened
Comment 26 Jaroslav Tulach 2010-11-03 17:37:57 UTC
(In reply to comment #25)
> 3. Changed URL of NetBeans UC to staging area [1]. Pressed "OK".

[1] I used following update center URL: http://bits.netbeans.org/netbeans/6.9.2/fixes/latest/uc/catalog.xml.gz
Comment 27 Jiri Kovalsky 2010-11-04 12:04:10 UTC
Confirming. Updating to Patch 2 per-partes helped and *.form files are now recognized correctly.
Comment 28 Jiri Kovalsky 2010-11-04 13:54:21 UTC
In spite of the above statement, when I installed full distro of 6.9 and updated the updater plugin and then the rest of Patch 2 modules, it didn't recognize the *.form files. However, installing the full distro of 6.9 from ZIP and updating the same way worked fine!

So, we are slowly getting there. Now it needs to resolve the usecase with using installer...
Comment 29 Jaroslav Tulach 2010-11-04 14:43:56 UTC
For some reason, when upgrading installer, the following module ends up in user directory:
ud/config/Modules/org-netbeans-modules-javafx-composer-components.xml

Just make it eager or autoload Petr.
Comment 30 Jaroslav Tulach 2010-11-04 14:50:23 UTC
The org-netbeans-modules-javafx-composer-components module seems to be new since 6.9 version and ergonomics don't handle new modules very well. Making it eager will very likely solve the problem. Btw. may the module NBM is also missing target cluster value (as it ended up in my userdir).
Comment 31 Rastislav Komara 2010-11-04 18:49:33 UTC
The module was marked eager. I don't see any other difference between any other module and this one connected with suite configuration. The target is set, and everything looks OK. 

CS #d56ed9c22bb2

Is is in main repo, if the problem persists, verify if this changeset is present.
Comment 32 Marian Mirilovic 2010-11-05 08:08:57 UTC
There is still pending problem with install as root/update as regular user scenario, see Issue 191657
Comment 33 puce 2011-02-25 18:25:24 UTC
I'm experiencing the same issue:
- I deleted the netbeans directories in my user directory
- updated the IDE after restart
Comment 34 Adam Sotona 2011-02-28 10:25:22 UTC
Reported test case was verified.
What is exactly your issue? Which version you've installed first and what update did you perform? 
Does disabling or uninstallation the Ergonomics help?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo