Bug 191261 - unable to save file and subsequently lost edits
unable to save file and subsequently lost edits
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 15:15 UTC by slreynolds
Modified: 2010-11-18 16:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Messages log timestamp Fir Oct 2010 10am (36.46 KB, text/x-log)
2010-10-25 14:37 UTC, slreynolds
Details
Messages log timestamp Thur Oct 22 2010 (37.14 KB, text/x-log)
2010-10-25 14:39 UTC, slreynolds
Details
Messages log timestamp Thur Oct 22 2010 5:11PM (42.76 KB, text/x-log)
2010-10-25 14:40 UTC, slreynolds
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slreynolds 2010-10-22 15:15:51 UTC
I was editing a Java file that had been created many days ago. After some time editing, I realized that when I made changes to the file in the Netbeans editor,  I was unable to save the file. The File -> Save menu item remained grey-ed out even though I made some more changes to the file. 

I then exited Netbeans (clicked the close button on the upper right corner). Netbeans, detected that I had unsaved changes, and prompted me if I wanted to save them. I chose the option to please save my changes, and then Netbeans finished shutting down normally.

I then restarted Netbeans, and looked that the file I was editing. All my changes were lost -- they were not saved.  

The file being edited is on a local file system, it is not on an NTFS file system and it is not served to any others by NTFS either. 

After the restart, Netbeans edited the file without any problem going forward.

I am not able to duplicate this problem.

I ranked this bug as P1 because I lost my edit changes.
Comment 1 slreynolds 2010-10-22 15:23:54 UTC
Sorry, I meant NFS, not NTFS. The file being edited is not served by Network File System by this computer or any other computer.
Comment 2 David Strupl 2010-10-22 15:27:16 UTC
Without further information I am closing the report as "incomplete". As the behavior is not repeatable I am downgrading the priority as well.

If we are to proceed any further we will need at least content of the file .netbeans/6.9/var/log/messages.log whether it contains anything that could hint as to what should have gone wrong. After attaching the file please reopen. Thanks for your understanding.
Comment 3 slreynolds 2010-10-25 14:37:51 UTC
Created attachment 102613 [details]
Messages log timestamp Fir Oct 2010 10am 

Not much seems interesting in this file. Including for completeness.
Comment 4 slreynolds 2010-10-25 14:39:07 UTC
Created attachment 102614 [details]
Messages log timestamp Thur Oct 22 2010

Not much seems interesting; including for completeness.
Comment 5 slreynolds 2010-10-25 14:40:46 UTC
Created attachment 102615 [details]
Messages log timestamp Thur Oct 22 2010 5:11PM

Interesting IndexOutOfBoundsException in this one
Comment 6 slreynolds 2010-10-25 14:41:42 UTC
I attached requested log files.
Comment 7 Stanislav Aubrecht 2010-11-18 16:08:28 UTC

*** This bug has been marked as a duplicate of bug 180960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo