Bug 191079 - LowPerformance took 82463 ms.
LowPerformance took 82463 ms.
Status: RESOLVED DUPLICATE of bug 192845
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P3 with 1 vote (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-18 10:07 UTC by Exceptions Reporter
Modified: 2012-04-19 12:44 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (28.16 KB, application/nps)
2010-10-18 10:07 UTC, Exceptions Reporter
Details
nps snapshot (41.14 KB, application/nps)
2010-11-30 12:22 UTC, eventlistener
Details
screenshot (245.64 KB, image/png)
2012-03-21 13:42 UTC, Milos Kleint
Details
screenshot csp (175.28 KB, image/png)
2012-03-21 13:48 UTC, Milos Kleint
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-10-18 10:07:08 UTC
Build: NetBeans IDE 6.9.1 (Build 201007282301)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows XP

User Comments:
GUEST: "Opening projects" at startup -- 17 separate Maven projects, < 10,000 LOC total



Maximum slowness yet reported was 82463 ms, average is 24497
Comment 1 Exceptions Reporter 2010-10-18 10:07:16 UTC
Created attachment 102452 [details]
nps snapshot
Comment 2 David Strupl 2010-10-18 15:53:55 UTC
Maven please evaluate first.
Comment 3 eventlistener 2010-11-30 12:22:36 UTC
Created attachment 103460 [details]
nps snapshot
Comment 4 lawaa 2011-06-08 10:41:25 UTC
Was opening a maven project with whole a lot of dependencies
Comment 5 Milos Kleint 2012-03-21 13:42:41 UTC
Created attachment 117010 [details]
screenshot

in the saxparser screenshot a checkstyle document is parsed and network checked in the process. the current codebase has entity resolver delegating to local files.
Comment 6 Milos Kleint 2012-03-21 13:48:53 UTC
Created attachment 117011 [details]
screenshot csp
Comment 7 Milos Kleint 2012-03-21 13:53:54 UTC
in other scenarios the ProjectAwareCodeStylePreferences.getCsp() method in awt is blocked by other thread in the method. That one in turn is blocked by the maven project loading. Which is however happening off-awt (correctly)

The maven project loading apparently has to happen sometimes and the fact is that it takes time. ProjectAwareCodeStylePreferences.getCsp() method wrongly assumes that getting project preferences is a cheap operation.
Comment 8 Dusan Balek 2012-04-19 12:44:28 UTC

*** This bug has been marked as a duplicate of bug 192845 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo