Bug 190794 - Deadlock after invoking Mercurial -> Revert on a maven project w/ pom files open
Deadlock after invoking Mercurial -> Revert on a maven project w/ pom files open
Status: RESOLVED DUPLICATE of bug 187615
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-06 05:24 UTC by _ tboudreau
Modified: 2010-10-06 12:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (18.79 KB, text/plain)
2010-10-06 05:24 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2010-10-06 05:24:01 UTC
Created attachment 102279 [details]
Thread dump

(not sure where Maven went in the bug page's project list, sorry if this is misfiled)

After warm start, opened the POM file in the editor and modified its dependencies.  Added one unit test class.  Then realized I was changing the wrong project and invoked Mercurial > Revert in the project view, with the new test file visible in the editor.  

Immediately got the attached deadlock - Swing document lock problem.
Comment 1 Jesse Glick 2010-10-06 12:30:53 UTC
Well-known bug with fix in dev builds, I just do not have physical authority to push an update.

*** This bug has been marked as a duplicate of bug 187615 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo