Bug 190749 - Java ME: Activation failed: Not all requested modules can be enabled
Java ME: Activation failed: Not all requested modules can be enabled
Status: RESOLVED FIXED
Product: javame
Classification: Unclassified
Component: -- Other --
7.2
PC Windows 7
: P3 with 2 votes (vote)
: 7.3
Assigned To: Anton Chechel
issues@mobility
:
Depends on: 221836
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 13:37 UTC by chmj
Modified: 2013-03-15 19:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
not all request modules (2.35 KB, patch)
2013-03-15 19:16 UTC, pirataxa
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description chmj 2010-10-04 13:37:29 UTC
Product Version = NetBeans IDE 6.9.1 (Build 201007282301)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_18
Runtime = Java HotSpot(TM) Client VM 16.0-b13

Activation failed: Not all requested modules can be enabled: [StandardModule:org.netbeans.modules.mobility.end2end.kit jarFile: C:\Program Files\NetBeans 6.9.1\mobility\modules\org-netbeans-modules-mobility-end2end-kit.jar]
Comment 1 Adam Sotona 2010-10-21 08:54:09 UTC
Mentioned module has been removed, please describe how to reproduce this case.
Comment 2 akailee 2010-10-26 06:47:28 UTC
我今天安装了,也出现类似情况,WINDOWS7,最先我安装了NETBEANS6.1,然后卸载了,在下载了完全版的6.9.1,定制安装了,IDE,JAVASE,J2ME,插件,结果也出现了,选择样例java me->通过游戏生成器创建简单的游戏.出现错误.
Activation failed: Not all requested modules can be enabled:
[StandardModule:org.netbeans.modules.mobility.end2end.kit jarFile: C:\Program
Files\NetBeans
6.9.1\mobility\modules\org-netbeans-modules-mobility-end2end-kit.jar]


产品版本: NetBeans IDE 6.9.1 (Build 201007282301)
Java: 1.6.0_10-rc2; Java HotSpot(TM) Client VM 11.0-b15
系统: Windows Vista 版本 6.1 运行于 x86 上; GBK; zh_CN (nb)
用户目录: C:\Users\MU\.netbeans\6.9
Comment 3 chmj 2010-11-12 13:00:48 UTC
(In reply to comment #1)
> Mentioned module has been removed, please describe how to reproduce this case.

I simply installed 6.9.1 and the I went on to install the Java ME extensions and got that error.
Comment 4 vali 2010-12-05 13:44:23 UTC
This error happens only if Java ME is installed without Java EE. (I have features on demand enabled.)

Workaround:
When you install Java EE, everything works as it should.

But this is not a solution. I and many others perhaps do not want to install another stuff (Java EE) to be able write just MIDP applications.
Comment 5 Adam Sotona 2010-12-06 08:11:20 UTC
It has been already fixed by removing mentioned module from the production builds and from the source repository.
This is configuration problem of "Features on demand" so the workarounds are:
- install NB 7.0 Beta
- or install also J2EE into NB 6.9.1
- or disable/do not install "Features on demand"
Comment 6 vitalyster 2011-08-03 17:58:33 UTC
reproduced in Netbeans 7.0.1
Comment 7 Anton Chechel 2011-08-04 12:45:38 UTC
Please describe your configuration and whether JavaEE support installed.
As described above this is "Features on demand" issue, not mobility.

I have just checked on my machine:
===
Product Version: NetBeans IDE 7.0.1 (Build 201107282000)
Java: 1.6.0_23; Java HotSpot(TM) 64-Bit Server VM 19.0-b09
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
===
Works for me.
Comment 8 drussilla 2012-01-08 23:10:09 UTC
Activation failed: Not all requested modules can be enabled:
[StandardModule:org.netbeans.modules.mobility.kit jarFile: /home/druss/NetBeans
6.9.1/mobility/modules/org-netbeans-modules-mobility-kit.jar]

Product Version: NetBeans IDE 7.1 (Build 201112071828)
Java: 1.7.0_147-icedtea; OpenJDK 64-Bit Server VM 21.0-b17
System: Linux version 3.0.0-15-generic running on amd64; UTF-8; en_US (nb)
User directory: /home/druss/.netbeans/7.1
Cache directory: /home/druss/.netbeans/7.1/var/cache

J2EE not installed, "Features on demand" installed.
Comment 9 drussilla 2012-01-08 23:15:11 UTC
After installing J2EE all works fine.

P.S. In previous comment I made a mistake (should be "/home/druss/netbeans-7.1/mobility/modules/org-netbeans-modules-mobility-kit.jar" instead of "/home/druss/NetBeans
6.9.1/mobility/modules/org-netbeans-modules-mobility-kit.jar")
Comment 10 Flexx 2012-07-29 01:12:32 UTC
I just reproduced this with 

Product Version: NetBeans IDE 7.2 (Build 201207171143)
Java: 1.7.0_05; Java HotSpot(TM) 64-Bit Server VM 23.1-b03
System: Windows Vista version 6.0 running on amd64; Cp1252; de_AT (nb)

Activation failed: Not all requested modules can be enabled: [StandardModule:org.netbeans.modules.mobility.kit jarFile: C:\Program Files\NetBeans 7.2\mobility\modules\org-netbeans-modules-mobility-kit.jar]

Even if there is the workaround to install the J2EE module (which should not be required for J2ME development), and/or disabling the "Features on Demand" option, the bug itself is not fixed. Thus, "RESOLVED WORKSFORME" doesn't quite apply.
Comment 11 JimmyX32 2012-08-02 12:14:54 UTC
(In reply to comment #10)
> I just reproduced this with 
> 
> Product Version: NetBeans IDE 7.2 (Build 201207171143)
> Java: 1.7.0_05; Java HotSpot(TM) 64-Bit Server VM 23.1-b03
> System: Windows Vista version 6.0 running on amd64; Cp1252; de_AT (nb)

Confirmed also with this configuration:

Product Version: NetBeans IDE 7.2 (Build 201207171143)
Java: 1.7.0_01; Java HotSpot(TM) Client VM 21.1-b02
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

The requested modules are there (in F:\Program Files\NetBeans 7.2\enterprise\modules\), but can't be enabled (whatever it means).

Moreover, what's confusing for me:
1.) If I install JavaME using the NetBeans installer, why should I activate it somewhere (is this extra step really necessary)?
2.) The dependency of JavaME on JavaEE (as described by vali/Cmt#4) and no warning/error message leading to the right solution.
Comment 12 Jiri Rechtacek 2012-12-06 11:15:43 UTC
Fixed - see the issue 221836.
Comment 13 pirataxa 2013-03-15 19:16:24 UTC
Created attachment 132668 [details]
not all request modules


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo