Bug 190530 - Projects sometimes fail to load: "Detected the following recursive expression cycle: []"
Projects sometimes fail to load: "Detected the following recursive expression...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
: RANDOM
: 190556 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-22 16:24 UTC by Jesse Glick
Modified: 2010-09-25 02:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-09-22 16:24:10 UTC
Apparently at random, sometimes certain open Maven projects are listed with warning badges as "empty-project". The problem list says e.g.

13 problems were encountered while building the effective model for org.apache.maven:maven-model:3.0-RC1
[ERROR] Resolving expression: '${project.artifactId}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
[ERROR] Resolving expression: '${project.version}': Detected the following recursive expression cycle: [] @ 
 for project org.apache.maven:maven-model:3.0-RC1 at .../maven-model/pom.xml

Reloading the project does not help, nor does Revalidate, nor closing and reopening. The only apparent fix is to restart the IDE.
Comment 1 Jesse Glick 2010-09-22 16:41:53 UTC
Any clue what this error message means?
Comment 2 Jesse Glick 2010-09-22 17:49:45 UTC
I also see the label "empty-project" very briefly when first opening the project group, but it is then (normally) replaced almost immediately by the real project <name>.
Comment 3 Jesse Glick 2010-09-22 23:34:05 UTC
In plexus-interpolation.
Comment 4 Jesse Glick 2010-09-23 10:40:49 UTC
*** Bug 190556 has been marked as a duplicate of this bug. ***
Comment 5 Jesse Glick 2010-09-23 11:29:15 UTC
org.codehaus.plexus.interpolation.InterpolationCycleException: Resolving expression: '${project.artifactId}': Detected the following recursive expression cycle: []
        at org.codehaus.plexus.interpolation.StringSearchInterpolator.interpolate(StringSearchInterpolator.java:185)
        at org.codehaus.plexus.interpolation.StringSearchInterpolator.interpolate(StringSearchInterpolator.java:124)
        at org.apache.maven.model.interpolation.AbstractStringBasedModelInterpolator.interpolateInternal(AbstractStringBasedModelInterpolator.java:241)
        at org.apache.maven.model.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.traverseObjectWithParents(StringSearchModelInterpolator.java:158)
        at org.apache.maven.model.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.traverseObjectWithParents(StringSearchModelInterpolator.java:305)
        at org.apache.maven.model.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.run(StringSearchModelInterpolator.java:122)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.apache.maven.model.interpolation.StringSearchModelInterpolator.interpolateObject(StringSearchModelInterpolator.java:75)
        at org.apache.maven.model.interpolation.StringSearchModelInterpolator.interpolateModel(StringSearchModelInterpolator.java:58)
        at org.apache.maven.model.building.DefaultModelBuilder.interpolateModel(DefaultModelBuilder.java:643)
        at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:339)
        at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:232)
        at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:135)
        at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:98)
Comment 6 Jesse Glick 2010-09-23 11:39:54 UTC
Filed for better future diagnosis: http://jira.codehaus.org/browse/PLXCOMP-158
Comment 7 Jesse Glick 2010-09-23 11:49:05 UTC
With PLXCOMP-158:

Resolving expression: '${project.artifactId}': Detected the following recursive expression cycle in 'project.artifactId': [artifactId, version] @ 
 for project org.codehaus.mojo.archetypes:ear-javaee6:1.2-SNAPSHOT at .../mojo-archetypes/ear-javaee6/pom.xml
Comment 8 Jesse Glick 2010-09-23 12:23:46 UTC
Filed http://jira.codehaus.org/browse/PLXCOMP-159 in case that is the cause.
Comment 9 Jesse Glick 2010-09-23 16:46:15 UTC
Filed http://jira.codehaus.org/browse/MNG-4836 to incorporate both PLXCOMP fixes and get on the radar for 3.0 RC3.
Comment 10 Jesse Glick 2010-09-23 23:46:51 UTC
MNG-4836 fixed in trunk.
Comment 11 Jesse Glick 2010-09-24 13:52:00 UTC
Trying a hotfix until RC3 is released: core-main #5fcf1ed733b6
Comment 12 Quality Engineering 2010-09-25 02:58:05 UTC
Integrated into 'main-golden', will be available in build *201009250000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d233b79e5ab8
User: Jesse Glick <jglick@netbeans.org>
Log: Diagnostics for #190530.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo