Bug 190259 - Deadlock between StatusProvider and AWT-EventQueue
Deadlock between StatusProvider and AWT-EventQueue
Status: RESOLVED DUPLICATE of bug 187615
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 10:28 UTC by dlichtenberger
Modified: 2010-09-20 22:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlichtenberger 2010-09-09 10:28:33 UTC
When invoking a Maven action (rebuild with dependencies), Netbeans 6.9.1 locked up. jstack found the following deadlock:

Found one Java-level deadlock:
=============================
"StatusProvider":
  waiting to lock monitor 0x08fe5638 (object 0x76750af0, a org.openide.windows.CloneableOpenSupport$Listener),
  which is held by "AWT-EventQueue-1"
"AWT-EventQueue-1":
  waiting to lock monitor 0x0917ad2c (object 0x74194328, a org.netbeans.modules.maven.model.pom.impl.POMModelImpl),
  which is held by "StatusProvider"

Java stack information for the threads listed above:
===================================================
"StatusProvider":
	at org.openide.text.CloneableEditorSupport.openDocument(CloneableEditorSupport.java:806)
	- waiting to lock <0x76750af0> (a org.openide.windows.CloneableOpenSupport$Listener)
	at org.openide.text.DataEditorSupport.openDocument(DataEditorSupport.java:496)
	at org.netbeans.modules.maven.model.Utilities._getDocument(Utilities.java:168)
	at org.netbeans.modules.maven.model.Utilities.access$000(Utilities.java:93)
	at org.netbeans.modules.maven.model.Utilities$1.getLookup(Utilities.java:226)
	at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:80)
	at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:155)
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.needsSync(AbstractDocumentModel.java:118)
	at org.netbeans.modules.xml.xam.AbstractModel.sync(AbstractModel.java:278)
	- locked <0x74194328> (a org.netbeans.modules.maven.model.pom.impl.POMModelImpl)
	at org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.findHints(StatusProvider.java:139)
	at org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.checkHints(StatusProvider.java:130)
	at org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.access$000(StatusProvider.java:100)
	at org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl$1$1.run(StatusProvider.java:114)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
"AWT-EventQueue-1":
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.getAccess(AbstractDocumentModel.java:571)
	- waiting to lock <0x74194328> (a org.netbeans.modules.maven.model.pom.impl.POMModelImpl)
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.documentChanged(AbstractDocumentModel.java:147)
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.access$100(AbstractDocumentModel.java:79)
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel$DocumentChangeListener.insertUpdate(AbstractDocumentModel.java:205)
	at org.netbeans.modules.xml.xam.dom.AbstractDocumentModel$WeakDocumentListener.insertUpdate(AbstractDocumentModel.java:189)
	at org.netbeans.lib.editor.util.swing.PriorityDocumentListenerList.insertUpdate(PriorityDocumentListenerList.java:82)
	at javax.swing.text.AbstractDocument.fireInsertUpdate(AbstractDocument.java:185)
	at org.netbeans.editor.BaseDocument.fireInsertUpdate(BaseDocument.java:1661)
	at org.netbeans.editor.BaseDocument.insertString(BaseDocument.java:810)
	at org.netbeans.editor.Analyzer.read(Analyzer.java:605)
	at org.netbeans.editor.BaseDocument.read(BaseDocument.java:1489)
	at org.netbeans.editor.BaseKit.read(BaseKit.java:701)
	at org.netbeans.modules.xml.text.TextEditorSupport.loadFromStreamToKit(TextEditorSupport.java:309)
	at org.openide.text.CloneableEditorSupport.loadDocument(CloneableEditorSupport.java:2132)
	at org.openide.text.CloneableEditorSupport.access$2800(CloneableEditorSupport.java:126)
	at org.openide.text.CloneableEditorSupport$Listener.run(CloneableEditorSupport.java:2962)
	at org.openide.text.CloneableEditorSupport$6$1Query.call(CloneableEditorSupport.java:1697)
	at org.openide.text.CloneableEditorSupport$6.run(CloneableEditorSupport.java:1708)
	at org.netbeans.editor.GuardedDocument.runAtomic(GuardedDocument.java:314)
	at org.openide.text.NbDocument.runAtomic(NbDocument.java:422)
	at org.openide.text.CloneableEditorSupport.reloadDocument(CloneableEditorSupport.java:1658)
	at org.openide.text.CloneableEditorSupport.checkReload(CloneableEditorSupport.java:2292)
	- locked <0x76750af0> (a org.openide.windows.CloneableOpenSupport$Listener)
	at org.openide.text.CloneableEditorSupport.access$2600(CloneableEditorSupport.java:126)
	at org.openide.text.CloneableEditorSupport$Listener$1.run(CloneableEditorSupport.java:2928)
	at org.netbeans.editor.GuardedDocument.runAtomic(GuardedDocument.java:314)
	at org.openide.text.NbDocument.runAtomic(NbDocument.java:422)
	at org.openide.text.CloneableEditorSupport$Listener$1.run(CloneableEditorSupport.java:2920)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:137)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Found 1 deadlock.
Comment 1 Jesse Glick 2010-09-20 22:10:52 UTC

*** This bug has been marked as a duplicate of bug 187615 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo