Bug 190246 - 23s in autoupdate.ui.Utilities.makeUpdateCategories() & createVisibleModulesDependecyMap()
23s in autoupdate.ui.Utilities.makeUpdateCategories() & createVisibleModulesD...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 7.3
Assigned To: Jiri Rechtacek
au-issues
EXCEPTIONS_REPORT perf-profileme
: API, API_REVIEW_FAST, PERFORMANCE
: 213862 217623 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-08 20:17 UTC by alfbennett
Modified: 2012-11-08 20:07 UTC (History)
19 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (13.87 KB, application/nps)
2010-09-08 20:17 UTC, alfbennett
Details
Profiler snapshot after slowness (17.89 KB, application/x-netbeans-profiler)
2011-05-16 01:54 UTC, rweaver
Details
Thread dump (33.49 KB, application/octet-stream)
2011-05-16 01:57 UTC, rweaver
Details
proposed api change (3.42 KB, patch)
2012-10-29 16:23 UTC, Jiri Rechtacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alfbennett 2010-09-08 20:17:04 UTC
Build: NetBeans IDE 6.9.1 (Build 201007282301)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows XP

User Comments:
esmithbss: Expanding the list of installed plugins.

alfbennett: Trying to load a web service



Maximum slowness yet reported was 30242 ms, average is 21427
Comment 1 alfbennett 2010-09-08 20:17:09 UTC
Created attachment 101950 [details]
nps snapshot
Comment 2 rweaver 2011-05-16 01:54:19 UTC
Created attachment 108305 [details]
Profiler snapshot after slowness
Comment 3 rweaver 2011-05-16 01:57:19 UTC
Thread dump from NB, still running slow Maven repository transfer at 40%
Comment 4 rweaver 2011-05-16 01:57:27 UTC
Created attachment 108306 [details]
Thread dump
Comment 5 Jiri Rechtacek 2012-06-26 10:03:40 UTC
*** Bug 213862 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Rechtacek 2012-10-05 11:17:43 UTC
*** Bug 217623 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Rechtacek 2012-10-29 16:23:36 UTC
Created attachment 126737 [details]
proposed api change

Counting of visible parents in Autoupdate UI is very expensive, finding for visible parents in Autoupdate Services can work smoothly. I proposed to add new methods to UpdateUnit which returns a visible ancestor of UpdateUnit if any. Autoupdate UI will use it instead of complex searching.
Thanks for review.
Comment 8 Jiri Rechtacek 2012-10-29 16:24:38 UTC
Counting of visible parents in Autoupdate UI is very expensive, finding for
visible parents in Autoupdate Services can work smoothly. I proposed to add new
methods to UpdateUnit which returns a visible ancestor of UpdateUnit if any.
Autoupdate UI will use it instead of complex searching.
Thanks for review.
Comment 9 Jiri Rechtacek 2012-11-01 00:22:49 UTC
http://hg.netbeans.org/core-main/rev/14d6d70ddb3f


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo