Bug 190182 - Optimize access to maven repository indexes
Optimize access to maven repository indexes
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Antonin Nebuzelsky
issues@projects
: PERFORMANCE, UI
: 186990 (view as bug list)
Depends on: 191637 193456 195541
Blocks: 189312
  Show dependency treegraph
 
Reported: 2010-09-06 12:10 UTC by Antonin Nebuzelsky
Modified: 2011-02-16 21:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2010-09-06 12:10:37 UTC
Maven repository indexes are queried from various features of Maven Support and currently the queries are blocked unnecessarily long in the following cases:

* the very first query trigeres local repository indexing and then download of remote indexes of all registered repositories - this query and all concurrent queries are blocked until all the indexes are downloaded - it usually takes minutes

-> for some UI, it makes sense to show the user incremental results as they become available, allowing the user to choose artifacts found in the local repository first (e.g. in Add Dependency dialog or in the hint searching for resolution of a missing class in the code).

* when an update of repository indexes (reindexing local or download of remote) gets started (usually automatically), queries are blocked until the update completes
Comment 1 Antonin Nebuzelsky 2010-09-06 12:31:10 UTC
Adding new variant of the repository query which uses an observable object to communicate incrementally found results of the query to the requester.

core-main #c327743ea64b

Using the new incremental repository query in Add Dependency dialog.

core-main #7c5775a29447
Comment 2 Quality Engineering 2010-09-07 03:12:29 UTC
Integrated into 'main-golden', will be available in build *201009070000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c327743ea64b
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #190182 - Optimize access to maven repository indexes (part 1)
Comment 3 Antonin Nebuzelsky 2010-09-07 14:27:15 UTC
Another use of the observable object in a query.

core-main #1da40f3757c4

And using the query in Search Dependency hint UI.

core-main #3622bc21acf4
Comment 4 Quality Engineering 2010-09-08 03:28:35 UTC
Integrated into 'main-golden', will be available in build *201009080000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c327743ea64b
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #190182 - Optimize access to maven repository indexes (part 1)
Comment 5 Antonin Nebuzelsky 2010-09-08 14:10:30 UTC
More improvements in

core-main #7c64607b8faf
core-main #4e69357f55ed
Comment 6 Quality Engineering 2010-09-09 03:05:55 UTC
Integrated into 'main-golden', will be available in build *201009090000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7c64607b8faf
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #190182 - Optimize access to maven repository indexes (part 3 cont.) - fixed a bug in repetitive searching in all repos instead of only in one...
Comment 7 Antonin Nebuzelsky 2010-09-15 16:17:56 UTC
Using the incremental repository query approach in Repository Browser window search facility.

core-main #c3334c70f6bf
Comment 8 Antonin Nebuzelsky 2010-09-15 16:19:16 UTC
Closing fixed for now.
Comment 9 Quality Engineering 2010-09-16 02:55:03 UTC
Integrated into 'main-golden', will be available in build *201009160000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c3334c70f6bf
User: Antonin Nebuzelsky <anebuzelsky@netbeans.org>
Log: #190182 - Optimize access to maven repository indexes (part 5)
Comment 10 Jesse Glick 2010-09-17 18:28:20 UTC
*** Bug 186990 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo