Bug 190112 - IndexOutOfBoundsException: Index: 3, Size: 3
IndexOutOfBoundsException: Index: 3, Size: 3
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-02 15:06 UTC by lazarius
Modified: 2010-09-14 13:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.77 KB, text/plain)
2010-09-02 15:06 UTC, lazarius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lazarius 2010-09-02 15:06:09 UTC
This bug was originally marked as duplicate of bug 180960, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 6.9.1 (Build 201007282301)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Windows 7

User Comments:
lazarius: Tried to open diff window from within the Subversion window.




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
   at java.util.ArrayList.RangeCheck(ArrayList.java:547)
   at java.util.ArrayList.get(ArrayList.java:322)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireIndicesChanged(DefaultTabDataModel.java:493)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setTabs(DefaultTabDataModel.java:123)
   at org.netbeans.core.windows.view.ui.tabcontrol.TabbedAdapter.setTopComponents(TabbedAdapter.java:237)
   at org.netbeans.core.windows.view.ui.TabbedHandler.setTopComponents(TabbedHandler.java:157)
Comment 1 lazarius 2010-09-02 15:06:13 UTC
Created attachment 101834 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2010-09-14 13:26:57 UTC

*** This bug has been marked as a duplicate of bug 180960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo