Bug 189820 - PHP refactoring does not rename files
PHP refactoring does not rename files
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Refactoring
7.0.1
All All
: P2 with 4 votes (vote)
: 7.4
Assigned To: Ondrej Brejla
issues@php
:
: 202613 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-25 07:46 UTC by Raazy
Modified: 2013-03-28 11:44 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raazy 2010-08-25 07:46:20 UTC
When refactoring a class name, please offer renaming a php file with class too when current class name matches with file name.

file: BaseModel.php
<?php
class BaseModel{

}
?>

In this scenario renaming a php file can be offered as well.

R.
Comment 1 Raazy 2010-08-26 11:34:49 UTC
More details here:
http://blogs.sun.com/netbeansphp/entry/rename_refactoring
Comment 2 nbphpuser 2010-08-26 15:34:52 UTC
Please also handle User.class.php filename pattern
Comment 3 Filip Zamboj 2010-09-15 12:33:06 UTC
batch reassigning
Comment 4 Raazy 2011-01-13 10:11:40 UTC
*bump*
Comment 5 Ondrej Brejla 2012-01-04 14:17:16 UTC
*** Bug 202613 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Brejla 2013-03-27 10:48:41 UTC
It has been implemented in the dev build.
Comment 7 Martin Kanak 2013-03-28 11:44:57 UTC
verified 

Product Version: NetBeans IDE Dev (Build 201303252300)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b02
System: Linux version 3.5.0-26-generic running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo