Bug 189751 - LowPerformance took 4990 ms.
LowPerformance took 4990 ms.
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P3 with 1 vote (vote)
: 7.0
Assigned To: David Strupl
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-22 11:12 UTC by TheJuice
Modified: 2010-08-30 09:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (6.05 KB, application/nps)
2010-08-22 11:12 UTC, TheJuice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TheJuice 2010-08-22 11:12:04 UTC
This bug was originally marked as duplicate of bug 185369, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201008210001)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
thejuice: Was editing basic Java code in a normal web project (JSF). NetBeans utilizes the max amount of CPU available constantly.
I only have one plugin - Tomcat 7.



Maximum slowness yet reported was 4990 ms, average is 4990
Comment 1 TheJuice 2010-08-22 11:12:08 UTC
Created attachment 101590 [details]
nps snapshot
Comment 2 David Strupl 2010-08-30 08:48:24 UTC
I will have a look at the snapshots....
Comment 3 David Strupl 2010-08-30 09:16:24 UTC
I am sorry but none of the snapshots attached to this issue shows anything useful that can lead to some improvements. I am closing this report as "works for me". If you are able to reproduce the problem in your setup (I mean that the IDE is frozen for considerable amount of time) please take several consecutive thread dumps and attach them to a newly reported problem. Thanks a lot for your understanding, more info about the thread dumps is here:
http://wiki.netbeans.org/GenerateThreadDump


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo