Bug 189682 - NullPointerException at java.io.Reader.<init>
NullPointerException at java.io.Reader.<init>
Status: RESOLVED DUPLICATE of bug 161435
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: David Konecny
issues@javaee
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 13:17 UTC by YohXF15
Modified: 2010-08-22 21:49 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.87 KB, text/plain)
2010-08-19 13:17 UTC, YohXF15
Details

Note You need to log in before you can comment on or make changes to this bug.
Description YohXF15 2010-08-19 13:17:29 UTC
This bug was originally marked as duplicate of bug 161435, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 6.9.1 (Build 201007282301)
VM: Java HotSpot(TM) Client VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Linux

User Comments:
GUEST: Create a new project

pjiricka: Creating a web project

GUEST: Creating a Web Application project for WebLogic

jsedek: creating new web application with JSF framework enabled

GUEST: clicked finish after creating a new java web project

jsedek: creating new Web project - pressed finished on Servers tab having Gv3 choosen as a server to use

xpilot: Tried to create new JSF+Hibernate project

jpospisil: Created Maven Calculator Sample and then invoked Java Web Project wizard

GUEST: Creating a new Java Web App project

GUEST: Trying to create a web project

GUEST: Was trying to create a new Web Project with Spring Web MVC framework.

GUEST: Create JSF web project with tomcat 6.0 and JSF 2.0

YohXF15: When o was creatint Dynamic Web page project null pointer exception occured.

GUEST: When I created a WebApplication

kluverkamp: Added apache 6.0.20 as a new server
create a new project, web one
JSF as framworks
and when i pressed finish, here is the problem




Stacktrace: 
java.lang.NullPointerException
   at java.io.Reader.<init>(Reader.java:61)
   at java.io.InputStreamReader.<init>(InputStreamReader.java:55)
   at org.netbeans.modules.web.project.api.WebProjectUtilities.readResource(WebProjectUtilities.java:902)
   at org.netbeans.modules.web.project.api.WebProjectUtilities.createProjectImpl(WebProjectUtilities.java:237)
   at org.netbeans.modules.web.project.api.WebProjectUtilities.access$000(WebProjectUtilities.java:126)
   at org.netbeans.modules.web.project.api.WebProjectUtilities$1.run(WebProjectUtilities.java:193)
Comment 1 YohXF15 2010-08-19 13:17:39 UTC
Created attachment 101527 [details]
stacktrace
Comment 2 Petr Jiricka 2010-08-19 14:16:50 UTC
Hello, but 161435 was fixed in the NetBeans 6.10 codebase, but NOT in 6.9.1.
So it is available in daily builds for the next release here: http://bits.netbeans.org/netbeans/trunk/nightly/

Could you please verify that it's fixed in these builds? Thanks.
Comment 3 David Konecny 2010-08-22 21:49:19 UTC
Please reopen if reproducible on 6.10.

*** This bug has been marked as a duplicate of bug 161435 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo