Bug 189580 - Pass (SOCKS) proxy settings to external maven command line
Pass (SOCKS) proxy settings to external maven command line
Status: RESOLVED DUPLICATE of bug 194916
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 10:21 UTC by reinouts
Modified: 2011-08-25 12:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description reinouts 2010-08-17 10:21:39 UTC
In the Netbeans Options window I've set a SOCKS5 proxy in the General tab.

However when using Maven, Netbeans doesn't pass any proxy options to the mvn command line. 
I have to manually add -DsocksProxyHost and -DsocksProxyPort in the Maven Global Excution Options to make it work.

Netbeans should pass the correct proxy options to Maven automatically.
Comment 1 Jesse Glick 2011-08-25 12:37:08 UTC

*** This bug has been marked as a duplicate of bug 194916 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo