Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 189534 - Code templates per project
Code templates per project
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
-S1S-
PC Windows XP
: P3 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 00:57 UTC by caesar2k
Modified: 2016-07-07 07:28 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description caesar2k 2010-08-16 00:57:25 UTC
Sometimes I have projects that I have to copy/paste some code, like titles, listings and PHP code, and would be very handy to have some code templates per project, for example, typing "tytle" would give me:

<h1 class="cufon white overlap raised"><?php echo $title; ?></h1>

or "tablelist"

<table>
<?php foreach($data as $r): ?>
<tr>
  <?php foreach($r->columns as $column): ?>
  <td><?php echo $column->name; ?></td>
  <?php endforeach; ?>
</tr>
<?php endforeach; ?>
</table>

since it's a lot of writing, a per project, depending on how many views, having the template ready is a time saver ;)
Comment 1 Martin Balin 2016-07-07 07:28:16 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo