Bug 189509 - new project is created not in utf-8
new project is created not in utf-8
Status: RESOLVED DUPLICATE of bug 153498
Product: python
Classification: Unclassified
Component: Editor
7.0
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Torbjorn Norbye
issues@python
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-14 11:14 UTC by nbphpuser
Modified: 2015-01-02 04:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nbphpuser 2010-08-14 11:14:53 UTC
NetBeans IDE 6.9.1

Create new project from existing sources dialog is using iso-8859-1 encoding by default and you cannot change it while creating project. So
localized strings are garbled if one then forget to change encoding in project dialog and edit files.

1. Start NetBeans
2. Create a project from existing sources with utf-8 files containing non-ASCII
3. Edit file with non-ASCII chars and save
4. non-ASCII chars are garbled


save file shouldn't change encoding, even if project declared as win-1252
Comment 1 Lou Dasaro 2015-01-02 04:50:39 UTC

*** This bug has been marked as a duplicate of bug 153498 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo