Bug 189473 - Persistence Entity Class From Database Generation -Field Name Issue
Persistence Entity Class From Database Generation -Field Name Issue
Status: RESOLVED DUPLICATE of bug 188550
Product: javaee
Classification: Unclassified
Component: Persistence
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Sergey Petrov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 07:56 UTC by visumagic
Modified: 2010-08-13 08:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description visumagic 2010-08-13 07:56:33 UTC
Hi

When I'm creating entities from database, the one-one many-one mappings are getting generated with field names as the entity class names. In NB6.8 it was on db table column field. 

There should be some option available to the user to choose. Because the reflecting the table columns names in the entity filed names will be accurate way of treating the entity. Foreign keys should get appended with index counts.

Fyi ..

http://forums.netbeans.org/post-80727.html

-raghu
Comment 1 Sergey Petrov 2010-08-13 08:16:28 UTC
this option is added in latest dev builds
see 188550
also as of number of requests it may have sense to change default to old behavior, currently default one is new with option to switch to old.

*** This bug has been marked as a duplicate of bug 188550 ***
Comment 2 Sergey Petrov 2010-08-13 08:18:08 UTC
please add link to resolved issue to the topic


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo