Bug 189382 - Deadlock when reverting changes (CVS)
Deadlock when reverting changes (CVS)
Status: RESOLVED DUPLICATE of bug 187615
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: David Simonek
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 09:15 UTC by Marian Petras
Modified: 2010-08-12 12:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
full thread-dump (generated by JVisualVM) (27.73 KB, text/plain)
2010-08-11 09:15 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2010-08-11 09:15:50 UTC
Created attachment 101304 [details]
full thread-dump (generated by JVisualVM)

I selected a directory node in the Favorites view and selected CVS > Revert Modifications. The IDE froze almost immediately. Later I found that modified files got reverted back to their base revisions (correct) and new files were not deleted (I do not know whether this is considered correct or incorrect).

I am not sure about which module contains the bug - reassign as needed.


The threads involved in the deadlock are:

   Default RequestProcessor:
        at o.n.m.xml.xam.dom.AbstractDocumentModel.getAccess(:571)
	- waiting to lock <0x2177ba68>
             (a o.n.m.maven.model.pom.impl.POMModelImpl)
	at o.n.m.xml.xam.dom.AbstractDocumentModel.getAccess(:79)
	at o.n.m.xml.xam.AbstractModel.isAutoSyncActive(:704)
        ...

   StatusProvider:
	at o.o.text.CloneableEditorSupport.openDocument(:806)
	- waiting to lock <0x216f16e0>
             (a o.o.windows.CloneableOpenSupport$Listener)
	at o.o.text.DataEditorSupport.openDocument(:496)
	at o.n.m.maven.model.Utilities._getDocument(:168)
	at ...
	at o.o.util.lookup.SimpleProxyLookup.lookup(:155)
	at o.n.m.xml.xam.dom.AbstractDocumentModel.needsSync(:118)
	at o.n.m.xml.xam.AbstractModel.sync(:278)
	- locked <0x2177ba68>
             (a o.n.m.maven.model.pom.impl.POMModelImpl)
	at o.n.m.maven.hints.pom.StatusProvider$StatusProviderImpl.findHints
                                                                       (:139)
        ...

   AWT-EventQueue-1:
	at o.n.m.xml.xam.dom.AbstractDocumentModel.getAccess(:571)
        - waiting to lock <0x2177ba68>
             (a o.n.m.maven.model.pom.impl.POMModelImpl)
        at o.n.m.xml.xam.dom.AbstractDocumentModel.documentChanged(:147)
        ...
	at o.n.editor.BaseDocument.remove(:959)
	at o.o.text.CloneableEditorSupport$4.run(:770)
	at o.n.editor.GuardedDocument.runAtomic(:314)
	at o.o.text.NbDocument.runAtomic(:422)
	at o.o.text.CloneableEditorSupport.clearDocument(:764)
	at o.o.text.CloneableEditorSupport.access$1700(:126)
        ...
	at o.o.text.CloneableEditorSupport.reloadDocument(:1658)
	at o.o.text.CloneableEditorSupport.checkReload(:2292)
	- locked <0x216f16e0> (a o.o.windows.CloneableOpenSupport$Listener)
	at o.o.text.CloneableEditorSupport.access$2600(:126)
	at o.o.text.CloneableEditorSupport$Listener$1.run(:2928)
        ...
Comment 1 Marian Petras 2010-08-11 09:18:33 UTC
NetBeans 6.9.1
JDK 6u21, 32-bit
Windows XP Professional SP 3
Intel Core 2 Quad CPU
Comment 2 Jesse Glick 2010-08-11 10:51:40 UTC
Yes, quite common deadlock. Probably you reverted pom.xml among other things.

*** This bug has been marked as a duplicate of bug 187615 ***
Comment 3 Marian Petras 2010-08-12 12:26:18 UTC
Yes, most probably I also reverted pom.xml.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo