Bug 189371 - Preview of code folding blocks
Preview of code folding blocks
Status: RESOLVED DUPLICATE of bug 189233
Product: editor
Classification: Unclassified
Component: Code folding
6.x
PC Linux
: P3 with 2 votes (vote)
: 6.x
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 06:31 UTC by rednaxela
Modified: 2010-10-20 18:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot for code folding block popUp (128.53 KB, image/png)
2010-08-11 06:31 UTC, rednaxela
Details
/var/log/messages.log (346.24 KB, text/x-log)
2010-08-11 10:53 UTC, rednaxela
Details
/var/log/messages.log (64.45 KB, text/x-log)
2010-08-16 06:18 UTC, rednaxela
Details
Wrong preview of collapsed code in JS editor in 6.9.1 IDE under Windows (7.37 KB, image/png)
2010-10-20 16:56 UTC, zvk77
Details
Wrong preview of collapsed code in PHP editor in 6.9.1 IDE under Windows (5.53 KB, image/png)
2010-10-20 17:11 UTC, zvk77
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rednaxela 2010-08-11 06:31:18 UTC
Created attachment 101295 [details]
Screenshot for code folding block popUp

Since several IDE-Updates the preview for code folding blocks is broken.
Instead of the code content in the popUp i only get to see the line numbers of this block, screenshot enclosed.
Error occurs in all editors (Java, JSP, XML, PHP, ...)
The code folding preview did fine after the initial installation.
Comment 1 rednaxela 2010-08-11 06:47:37 UTC
Bug also exists in Netbeans6.9.1 after initial installation on Linux platform
Comment 2 Peter Pis 2010-08-11 08:55:16 UTC
Could you please attach messages.log ? It is located in <nb_user_directory>/var/log
Comment 3 rednaxela 2010-08-11 10:53:58 UTC
Created attachment 101313 [details]
/var/log/messages.log

messages.log attached
Comment 4 Peter Pis 2010-08-12 07:41:05 UTC
From attached "messages.log" it seems that NB is missing some resources of installed modules and it could be (code content) a consequence of that. Could you please try to start NB with another fresh NB user directory?
http://wiki.netbeans.org/FaqAlternateUserdir

What is the result then?
Comment 5 rednaxela 2010-08-16 06:18:52 UTC
Created attachment 101404 [details]
/var/log/messages.log
Comment 6 rednaxela 2010-08-16 06:19:40 UTC
Same effect after starting the IDE with a new/clean user directory.
/var/log/messages.log attached
Comment 7 aleforla 2010-09-08 13:41:48 UTC
(In reply to comment #0)

My 6.9.1 IDE has the same defect (on Windows)
Comment 8 zvk77 2010-10-20 16:56:31 UTC
Created attachment 102525 [details]
Wrong preview of collapsed code in JS editor in 6.9.1 IDE under Windows

I have same problem in any editor in 6.9.1 IDE under Windows XP Pro!
I attach couple of screenshots. First is JavaScript editor.
Comment 9 zvk77 2010-10-20 17:11:46 UTC
Created attachment 102526 [details]
Wrong preview of collapsed code in PHP editor in 6.9.1 IDE under Windows

... and second screenshot taken in PHP editor.
In all other languages same error. :(

I think that problem in inaccurate detection (or setting) of popup box width. As we can see, on left side of popup block exists first letters of collapsed code ("fu" from "function", "p" from "private" et cetera...) So, my version of problem: preview of collapsed block created correctly, but have incorrect box width.

I hope this helps.
Comment 10 Michel Graciano 2010-10-20 18:12:21 UTC

*** This bug has been marked as a duplicate of bug 189233 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo