Bug 189358 - LowPerformance took 35171 ms.
LowPerformance took 35171 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 15:32 UTC by duepmeier
Modified: 2011-11-08 14:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (67.94 KB, application/nps)
2010-08-10 15:32 UTC, duepmeier
Details
nps snapshot (122.44 KB, application/nps)
2011-10-31 22:53 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description duepmeier 2010-08-10 15:32:17 UTC
Build: NetBeans IDE 6.9.1 (Build 201008030030)
VM: Java HotSpot(TM) Client VM, 17.0-b17, Java(TM) SE Runtime Environment, 1.6.0_21-b07
OS: Windows XP

User Comments:
duepmeier: Code completion is driving me nuts. Editing bigger Java projects is no fun with IDE versions 6.9 and 6.9.1 because code completion and functionalities depending on it freeze the IDE often for longer then 30 seconds (This was not the case using version 6.8).

Directly before the slow performance I used code completion on a @Table annotation to code complete the "name" attribute. As I observed already in many code completion situations the IDE freezes while doing code completion (often displaying a scanning or rescanning projects message). While watching the IDE with a separate process viewer I observe that the IDE takes 50% of the CPU time and after having the IDE open for a longer time I also observe swapping because the IDE consumes more and more memory (it's interesting to see that the "Working set size" is increasing: so the IDE is permanently working with an over the time increasing big data structure in main memory - maybe the database underneath the code completion is permanently



Maximum slowness yet reported was 35171 ms, average is 17266
Comment 1 duepmeier 2010-08-10 15:32:27 UTC
Created attachment 101287 [details]
nps snapshot
Comment 2 Dusan Balek 2010-08-27 16:56:39 UTC
As can be seen from the attached snapshot, the slow performance is caused by running the 'org.eclipse.persistence.internal.jpa.modelgen.CanonicalModelProcessor' which seems to be very slow. You could try to disable annotation processing in editor via Project Properties -> Build -> Compiling.
Comment 3 muellermi 2011-10-31 22:53:55 UTC
Created attachment 112627 [details]
nps snapshot
Comment 4 Dusan Balek 2011-11-08 14:07:37 UTC
As can be seen from the Exception Reporter, all slowness reports are caused by the slow execution of 'org.eclipse.persistence.internal.jpa.modelgen.CanonicalModelProcessor'. Annotation processing in editor can be disabled via Project Properties -> Build -> Compiling.

Closing as WONTFIX on NB side.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo