Bug 189297 - Fix submenu require click to appear which is inconsistent with other menus
Fix submenu require click to appear which is inconsistent with other menus
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
6.x
PC Other
: P3 with 1 vote (vote)
: 7.4
Assigned To: Roman Svitanic
issues@editor
: UI, UI_REVIEW
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-08 18:02 UTC by shunbul
Modified: 2013-07-12 02:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shunbul 2010-08-08 18:02:17 UTC
The UI for subfixes attached to a fix annotation is inconsistent with the rest of the NetBeans interface.  Other submenus in the IDE require only hovering to reveal the submenu. 

Accordingly, the submenu for a fix annotation should appear when the user hovers over the parent menu item.  The user should not have to click the small right-arrow.

It took me a while to figure out that fixes had submenus because of this inconsistent behaviour.
Comment 1 David Strupl 2012-12-17 09:21:15 UTC
Petr, can you pleas have a look? Thanks.
Comment 2 Petr Somol 2012-12-17 09:46:39 UTC
I checked this and confirm the inconsistency is there.

First I summarize what is the intended behavior, because it differs for mouse navigation and keyboard navigation. So in general in Netbeans:

- in a menu opened by mouse, the expected behaviour is as reported: hoovering the mouse over a submenu item should immediately show sub-menu items, and hide them when the mouse is moved elsewhere without click. However,
- in a menu opened by keyboard, where items are navigated by keyboard (arrows), sub-menus are not! opened when their representing item is reached. User needs to explicitly go to the submenu (right arrow) to display it.

The current hint pop-up behavior always follows the keyboard navigation style, regardless whether the pop-up has been opened by a keyboard shortcut (Alt-Enter) and navigated by keyboard or by mouse click to the little hint symbol to the left from the affected line and navigated by mouse.

From UEX point of view I believe the hint pop-up behavior should be the same as in other NB menus (e.g., the main menu). I.e., when the pop-up is navigated by keyboard, do not show submenus until user requests so by explicit keystroke (right arrow). However, if it is navigated by mouse, then sub-menus should be displayed on mouse over.

Reassigning to Hints owner.
Comment 3 Roman Svitanic 2013-07-11 09:36:18 UTC
fixed in jet-main:
http://hg.netbeans.org/jet-main/rev/800a868829e8

When user points with mouse cursor at the arrow of hint and submenu is available for that particular hint, then this submenu is opened.
Comment 4 Quality Engineering 2013-07-12 02:29:08 UTC
Integrated into 'main-silver', will be available in build *201307112300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/800a868829e8
User: Roman Svitanic <rsvitanic@netbeans.org>
Log: #189297 - Fix submenu require click to appear which is inconsistent with other menus


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo