Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 189253 - nb.org mailing lists accepting out-of-office autoreplies
nb.org mailing lists accepting out-of-office autoreplies
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Admin
7.0
PC Linux
: P1 with 4 votes (vote)
: TBD
Assigned To: Marco Walther
Admins
http://netbeans.org/projects/www/list...
KENAI
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 15:22 UTC by Jesse Glick
Modified: 2011-11-15 11:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-08-05 15:22:04 UTC
See URL for an example. I think this message is coming from a Beehive autoreply option, though Vince could confirm this when he gets back to work; there are similar ones from Steffen Grund. Some of these autoreply messages get posted through to the list; in other cases they are sent to moderator. I have seen many such messages from either Vince or Steffen go to moderator for api-changes@netbeans.org; I reject each one with the BLACKLIST option, but they still keep on coming (and anyway http://netbeans.org/projects/www/lists/api-changes/blacklist shows no entries although I have tried to blacklist plenty of spammers), I guess because the posters were on the whitelist before (shouldn't blacklisting someone remove them from the whitelist??).

Please make sure the Kenai mail system rejects attempts to post autoreplies to the list. Or if this is something that is supposed to be handled by the autoreplier based on well-known mailer headers (e.g. from EZMLM), make sure a ticket is filed for that.
Comment 1 Jiri Kovalsky 2010-08-05 18:37:25 UTC
Yes, this is very unfortunate. I had to unsubscribe Vince and another person from several mailing lists, because their auto responses were spamming community.
Comment 2 Vince Kraemer 2010-08-16 20:57:25 UTC
I think the issue is in the infrastructure that handles netbeans.org.

I had set up an auto-reply back in April with stbeehive, that did not seem to generate any of the 'heat' that the most recent auto-reply seemed to generate.

I am on a fairly broad range of lists.  The recent auto-reply did not seem to generate heat on any of the mailing lists that are handled by other infrastructure packages.
Comment 3 Jesse Glick 2010-08-16 21:02:11 UTC
Just started coming in from rohan.ranade@orcl.com to broken_builds@nb.org. Needs to be addressed.
Comment 4 tomwheeler 2011-04-05 17:10:43 UTC
There have been at least 10 out of office messages from Toni Epple (toni.epple@eppleton.de) on the dev@platform.netbeans.org list in the last 24 hours.  

I voted on this (in case it does any good at all) since this is really annoying.
Comment 5 Jan Pirek 2011-07-11 11:55:07 UTC
Kenai team, can you please give us some update wheather you plan to fix this? 

There has been new batch of these very recently and it's really annoying.

honza
Comment 6 maxnitribitt 2011-07-11 12:03:46 UTC
Sorry for the hazzl! I don't have this problem on other mailing lists. I don't know if they use phrase filters or other rules for filtering. It would be nice to have this for the NB mialing lists as well. Unsubscribing and resubscribing is something I'll probably forget quite regularly.

Thanks,

Toni 

BTW: I think unsubscribing someone is a good idea, but be sure to read the autoreply message, it usually tells how long the sender is away ( I was unsubscribed the day I returned ;-) ).
Comment 7 tomwheeler 2011-07-12 15:59:24 UTC
Like Jan, I am also interested in knowing from the Kenai team when this will be fixed.  

There are currently dozens of autoreplies from olivier.lagneau@oracle.com being sent to the dev@platform mailing list.  This is annoying to those who subscribe to that list and also reflects poorly on Oracle since those messages are coming from an oracle.com e-mail address.
Comment 8 Vince Kraemer 2011-07-12 16:25:05 UTC
Since Lea doesn't work for Oracle or on Kenai anymore, we might want to reassign this to an actual person that can and might do something to resolve the problem...

I do not know who that person would be...  If I did, these issues would be assigned to them when I committed this comment.
Comment 9 tomwheeler 2011-08-12 14:58:00 UTC
Based on Vince's comments, I changed the assignment to Marco so that he can assign it to someone who actually works on Kenai and can fix it.  

BTW, I will note that it is certainly possible to implement this with Sympa.  There is already a filter in place for netbeans.org which will reject messages to mailing lists with subject lines like 'unsubscribe'.  Adding another one which rejects messages containing "Auto Reply" in the subject or "out of office" in the message body is probably just a matter of copying an existing rule.
Comment 10 nicklas.lof 2011-08-12 15:07:04 UTC
Also this list are missing two mail headers that some auto repliers are checking before sending an autoreply:

Precedence: list
X-Auto-Response-Suppress: OOF, DR, RN, NRN
Comment 11 Jiri Kovalsky 2011-11-08 19:48:07 UTC
FYI, according to the latest news this issue has finally been fixed. Marco, is the fix deployed to current netbeans.org instance?
Comment 12 tomwheeler 2011-11-08 19:51:44 UTC
Also, as I mentioned in comment #4, the lists also propagate out-of-office replies which originate from e-mail addresses outside the oracle.com domain.  

The news I heard seemed to indicate that this would not be corrected by the fix.  Can you please confirm whether this is true or not?
Comment 13 Jiri Kovalsky 2011-11-09 10:43:43 UTC
Yes, the fix was on Oracle's side (mail server) so we are not there yet :( but at least NetBeans engineers can turn on automatic notification. If it helps, here is one of the auto-replies from Toni:

http://netbeans.org/projects/platform/lists/dev/archive/2011-04/message/69
Comment 14 maxnitribitt 2011-11-09 11:46:55 UTC
My (Toni's) "OUT OF OFFICE" replies have "Auto-submitted: auto-replied" set in the header. Can't the mailing lists reject or filter out these mails?
Comment 15 Marco Walther 2011-11-15 00:56:23 UTC
http://kenai.com/jira/browse/KENAI-3110
Comment 16 Jiri Kovalsky 2011-11-15 11:06:44 UTC
Marco, can you please explain the algorithm, which was used to avoid accepting OOO messages?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo